Netgear burnboardid tool - where to get it from?

In this thread, the burnboardid tool was mentioned:

I tried various firmwares from Netgear for WNDR4300 but none have the tool.

Where can I find this tool or is there a different way to change board ID from WNDR4300SW -> WNDR4300 ?

i got curious with the question hence i googled to see if i can find the burnboardid for the netgear wndr4300v1 and i can't find any information. does anyone know the burnboardid for the wndr4300?

FWIW, I don't know what I did to my WNDR4300-SW, I think it was modifying the very first Netgear stock firmware for regular WNDR400 so I can flash it on the SW version and now the hardware ID changed to just a normal WNDR4300. Exactly what I needed burnboardid for (which I was not able to locate). But I'm happy, I can flash any firmware I want on it now without changing the ID in the firmware and re-computing the checksum.

you mean you took the wndr4300 firmware v1.0.1.30 (initial release) and changed the ID from wndr4300 to wndr4300sw in the firmware and recomputed the checksum and that resulted in the burnboardid changed to the regular wndr4300?

Something like that. Though I think I also looked through the NVRAM for all the "WNDR4300SW" strings and changed them to "WNDR4300" though I don't think it's that easy to change the ID. Something fixed it, I tried many things, I can't pinpoint which one was the fix or which combo. It's not important to me at this point as I'm not getting another WNDR4300 unit, I just keep this one as a backup and if it dies it's not getting replaced. But it's a pretty decent unit to run as a wired router if you don't have high throughput requirements for WAN-LAN.

thanks for the insight. i've been modifying the firmware id and recomputing the checksum whenever i need to update hence it's not really a huge issue for me. i thought perhaps if there is a way for me to change the burnboarid permanently perhaps i can now skip the firmware id and checksum modification steps.

If you figure out what works, please post here, I'm curious and might help others too.

hmm... since your wndr4300sw has no problem accepting wndr4300 firmware, i wonder if your router burnboarid has already been updated to wndr4300's burnboardid? could you do a burnboardid command to reveal its burnboarid value?

I was never able to find the burnboardid tool, so not sure what to run -- is it included in OpenWRT? Router is not in use, it's sitting in some box.

this is the utility to find the burnboardid for netgear routers, the tool only works when the netgear router has factory firmware. i thought perhaps someone on this lede forum had the opportunity to find the burnboardid value for the wndr4300 and that is the value wndr4300sw owners should use to change the burnboardid value to.

All that tool does is enable telnet to the router. But where's the actual burnboardid executable? I was not able to find it in any Netgear firmwares for this model.

once you telenet to the router on netgear firmware, the command is burnboardid. the original netgear firmware shall return the burnboardid value.

I'm not sure how else to explain it, there is no burnboardid command/tool in any of the Netgear firmwares I tried.

i think you have explained it well. i don't have first hand experience with netgear firmware because i had flashed the wndr4300sw with the modified openwrt wndr4300 firmware via tftp.

perhaps if i have more spare time on my hands, i should flash my wndr4300sw with the original surewest wndr4300sw firmware and try if i can update it with the first netgear wndr4300 firmware to see if it will take. if not, try updating it with a modified netgear4300 firmware, then try updating to the next unmodified netgear firmware until it take. i think maybe this is how you may have accidentally changed the board id on your router. from my vantage point, it's definitely more work when my wndr4300sw is already running modified wndr4300 lede firmware. thanks again for your insight.