Netgear 7800: Downgrade after opkg update

I upgraded the 18.06.1 packages with opkg of my Netgear R7800 and now now Luci doesn't show the LAN configuration fields. How can I downgrade to standard 18.06.1?

I assume, that this doesn't make sense:

umount /overlay && firstboot && reboot

and the updated packages will be kept.


Wherever you grabbed that from appears someone pasted the & operator from a source with the wrong character set, as it should be: umount /overlay && /sbin/firstboot && reboot

This must be done with care, as Base packages should never be upgraded... if Base packages need to be updated, an updated firmware image must be flashed.

  • LuCI and any of it's app packages are packages that should never be upgraded with opkg, as they're kernel version dependent
1 Like
OpenWrt 18.06.1, r7258-5eb055306f
root@R7800:~# umount /overlay && firstboot && reboot
This will erase all settings and remove any installed packages. Are you sure? [N/y]
/dev/ubi0_1 is not mounted
/dev/ubi0_1 will be erased on next mount
writing /dev/ubi0_1 failed: Bad file descriptor

What now? Something with sysupgrade?

Create a backup tar (either via LuCI or sysupgrade), then issue: /sbin/firstboot

Or if there is something wrong with the updated core system packages, boot the router to the Openwrt failsafe mode and use "firstboot" there. Failsafe mode skips all your changes in overlay and only used the flashed orginal firmware.

With R7800 you can naturally also use the Netgear TFTP recovery flash mode to flash a new version via TFTP, but likely that is not necessary.

1 Like

What do you mean with backup?

I have done:

sysupgrade --create-backup /tmp/backup-`cat /proc/sys/kernel/hostname`-`d
ate +%F`.tar.gz; ls /tmp/backup*
dd if=/dev/mtd0 of=/tmp/boot.backup
dd if=/dev/$(grep -i '"art"' /proc/mtd |cut -c 1-4) of=/tmp/art.backup

Then I copied these files to the pc.

Is these enough for backups?

If I use tftp, which file I have to use then?

Do I need sysupgrade file fo the downgrade: instead of the factory file? Download link is from

I have no idea if there was more changed than the coresystem. I would be on the safe side and install everything new.

The factory image.
Just like explained in the R7800 device page and here in the forum.

Ps. forget about those backups. You want a clean setup. (and it makes no sense to backup the read-only art partition.)

Wouldn't you want a backup tar for the config files? I should have mentioned thats what I meant by backup.

Normally, sure.
But if the system is already messed up to some extent, there is no guarantee that the config files are sensible any more.

1 Like

I am not interested in a backup of the config files, I tried so much because of No internet connection from the router via ssh from time to time and I want the default configuration back.

So simply putting in /tmp and then via ssh

sysupgrade -n /tmp/openwrt-18.06.1-ipq806x-netgear_r7800-squashfs-sysupgrade.bin

is not a possible way? Sorry to ask again. This was the way to upgrade a 7-8 year old openwrt-router: TP-LINK TL-WR1043ND v1.8 Upgrade. But the difference now is, there is a downgrade of nearly thes same installation.

Yes, that should work. If it doesn't, you'll need to follow @hnyman's advice

Ok, so with sysupgrade the sysupgrade-file and with tftp the factory file. I am asking double, because the router has another network (192.168.178.x) and after flashing I cannot access to it with my pc anymore (not easily) and I have to lend a notebook.

Default OpenWrt subnet is, which is the subnet the router will have once flashed.

  • For your PC, simply disconnect the ethernet cable for ~5s, then plug in back in... it will generate a new DHCP request and your PC will be assigned an IP in the subnet.
    • If your PC is configured with a static IP on the PC's interface, simply change the IP to an IP in the aforementioned subnet (say .254), netmask to /24, and gateway as

Not so easy with the pc, it is a bridge with 2 NICs, forwarding and firewall-rules and I try not to touch the configuration. I only want to be sure not to flash the wrong file. Thanks! I will give feedback, when it is done.

You can configure a virtual interface with the IP assigned.

  • All Unix based OSes support this
  • Windows does, but only natively with Windows 10 Pro via Hyper-V.
    • If a home license, OpenVPN's TAP adapter is required to be installed (simply install OpenVPN), as the Windows TCP/IP stack is entirely different from Unix's, and doesn't support an interface without actual hardware attached to it.
root@R7800:/tmp# md5sum r7800.bin 
5531fac2763124d9c7fbe89835966e5c  r7800.bin
root@R7800:/tmp# sysupgrade -n /tmp/r7800.bin 
Commencing upgrade. Closing all shell sessions.
Connection to closed by remote host.
Connection to closed.

I renamed the bin file and it looks like everything worked fine. I am back to with the R7800 as before. Now I can go on (soon) with my network-problem discussed at No internet connection from the router via ssh from time to time

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.