Netatalk (Apple Time Machine) internal error after OpenWrt Upgrade

Dear OpenWrt forum users,
I installed OpenWrt v19.07 on a Linksys 1200AC rev. 1 in 2020 because I wanted to run Time Machine backups right from my router. I followed the OpenWrt guide for AFP Netatalk share configuration (Apple Time Machine) to the letter and everything worked great.
Skip ahead to today when I upgraded OpenWrt to version 21.02.3 because I wanted to add more functionality to my router. All my Netatalk setting carried over with the upgrade. I followed the AFP Netatalk share configuration install guide again to verify that all the config files were correct.
However, when attempting to log into the AFP server from Time Machine preference pane I receive an error: "There was an error authenticating with the provided username or password."
Finder sees the the AFP server but again gives an error "connection failed" when trying to log in.
When I look at /var/log/afpd.log I see the following error message:

May 10 14:25:41.301140 cnid_metad[2633] {cnid_metad.c:509} (note:AFPDaemon): CNID Server listening on lo>
May 10 14:25:41.499063 afpd[2632] {afp_config.c:174} (note:AFPDaemon): Netatalk AFP/TCP listening on int>
May 10 14:25:41.499304 afpd[2632] {dsi_tcp.c:476} (error:DSI): No suitable network config for TCP socket
May 10 14:25:41.499564 afpd[2632] {dsi_tcp.c:476} (error:DSI): No suitable network config for TCP socket
May 10 14:25:41.499699 afpd[2632] {dsi_tcp.c:476} (error:DSI): No suitable network config for TCP socket
May 10 14:25:41.499756 afpd[2632] {afp_config.c:190} (error:Default): no suitable network address found,>
May 10 14:25:41.499806 afpd[2632] {main.c:327} (error:AFPDaemon): main: no servers configured
May 10 14:25:46.512704 afpd[3318] {afp_config.c:174} (note:AFPDaemon): Netatalk AFP/TCP listening on int>
May 10 14:25:46.512884 afpd[3318] {afp_config.c:174} (note:AFPDaemon): Netatalk AFP/TCP listening on int>
May 10 14:25:46.513077 afpd[3318] {afp_config.c:174} (note:AFPDaemon): Netatalk AFP/TCP listening on int>
May 10 17:15:13.944630 afpd[3582] {auth.c:235} (note:AFPDaemon): Login by alex (AFP3.4)
May 10 17:15:14.048277 afpd[3582] {fault.c:123} (severe:Default): ======================================>
May 10 17:15:14.048378 afpd[3582] {fault.c:124} (severe:Default): INTERNAL ERROR: Signal 11 in pid 3582 >
May 10 17:15:14.048433 afpd[3582] {fault.c:125} (severe:Default): ======================================>

From the log file it looks like I successfully log in but there's also all that business about no suitable network address found.
I have tried changing the permissions of the backups folder to 777 as one thread suggested, but that did not clear the error. I've restarted everything multiple times.
Has anyone troubleshot this issue? I'm not averse to formatting my backup disk and starting again from scratch if that's the only fix.
Thanks to the OpenWrt team members who wrote the Apple Time Machine guide!

Hi, what version of macOS are you using?

Time machine moved to SMB / cifs in newer versions, AFP is deprecated.

Try sharing via Samba instead.

1 Like

Irregardless of your configuration and the log messages, a "signal 11" is a bug in the program.

1 Like

Thank you for the replies. I'm running macOS 12.3.1 Big Sur. I could however back up to my Time Machine drive hosted via AFP just fine before upgrading OpenWrt. Maybe the Netatalk bundles were never meant for the newest OpenWrt release since Apple is moving on from AFP...
In any event, since AFP is depreciated, I had better get ahead of the game and switch to Samba.
If I can make the switch without reformatting the drive I'll post my steps here in case another user has the same issue.

Update: Unfortunately, Apple Time Machine didn't want to play ball with me trying to swap one server protocol for another. I ended up deleting my old Time Machine backups and starting fresh. Not a big deal for me, but it might matter for someone else. I followed the OpenWrt Samba configuration guide and Time Machine works again.

Apologies to anyone who finds this thread while trying to fix their Netatalk problems.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.