Need to block a built in kernel driver but initcall_blacklist=k10temp fails to do so

For x86/64, the k10temp driver is built it (see https://github.com/openwrt/openwrt/blob/main/target/linux/x86/64/config-5.15#L416) but I am building a replacement module called zenpower3 which cannot co-exist with upstream's k10temp. I tried booting with the following in my kernel line but the k10temp driver is still active. Is there an easy way I can disable it?

initcall_blacklist=k10temp

Full grub entry:

menuentry "OpenWrt passive" {
  linux /boot/vmlinuz root=PARTUUID=7fe1d9bc-6bf4-44dc-b869-b213c3af5102 rootwait amd-pstate=passive console=tty0 console=ttyS0,115200n8 noinitrd initcall_blacklist=k10temp
}

I edited my post stating that the above did in fact work but that is not correct. The only thing that did work was building the image modifying https://github.com/openwrt/openwrt/blob/main/target/linux/x86/64/config-5.15#L416 to be a module.

Any suggestions for disabling k10temp without doing that?