Need major help with going back to OEM firmware [Solved]

Router: WRT1900ACS
Current Firmware: davidc502 LEDE build

Router has flashed the new firmware and everything works so far. I didn't really like the firmware so I wanted to flash back to the OEM to try DD-WRT instead. My problem is when I go to the System>Flash Firmware, it asks for the file to be chosen so I choose the latest OEM build for the router, I untick keep settings and press flash image and it gives me the following message--- " The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."
The file type is a .img so I don't know if that's the problem??

I attempted to flash the image via TFTP and still had no luck. Is there something i'm missing or doing wrong?

I'm not the best with this type of stuff so any detailed help or directions would help tremendously.
I've been trying to figure this out for the last week and I just give up.

You just need to flash with sysupgrade in a terminal using the force option -F, so copy your Linksys firmware to /tmp, ssh in, cd to /tmp and run -

sysupgrade -n -F linksysfirmware.img

1 Like

Do I have to rename the file to linksysfirmware.img?

Also, thank you for the quick response

No, keep the original name, i was just using linksysfirmware.img as an example.

Pardon my language but holy HELL it worked. You don't understand how much frustration I've gone through. I've tried tftp, downloaded previous versions of firmware, I tried getting the router into management, etc. Thank you so much.

Hi.. I'm new in this of flashing my router, but how can I copy the Linksys file to the /tmp? I don't have so much experience in use putty..

I want to recover my router to Linksys software

Download a copy of WinSCP... it's a file transfer tool that works just like explorer for moving files around. :slight_smile:


Thanks a lot!!!!

I did it!!!