Need help with VLAN on 24.10

I'm trying to upgrade my home network from openwrt 21.xx to 24.10.

Started with some GS108Tv3 switches.
All VLAN's (id 3 to 8) are tagged on physical port 1 and 8
VLAN 3 is untagged at phyical port 3
When I connect a device to physical port 3, the device gets an ip from the main router = dhcp server out of the defined range of VLAN 3.
So I think everything works as expected.

But now I'm struggling with a WDR4900. I would like to run the device as switch too. Maybe I will upgrade to a Dumb-AP with WiFi later ...
What I have done as first steps.

  • removed all firewall rules
  • remove interfaces wan, wan6
  • disabled dhcp server on interface lan
  • changed protocol to DHCP client on interface lan
  • added physical port "wan" to device br-lan

With this done I can connect a device to every physical port. As long as any Port is connected to an uplink port of another switch, the connected devices will get an IP Address via DHCP.
Fine.

Then I'm trying to get VLAN working.
Via Luci -> Network -> Interfaces -> devices

  • added VLAN (802.1q) devices with VLAN id to br-lan ==> got new devices br-lan.3 .. br-lan.8
  • added interfaces. one per VLAN
  • configured device br-lan
    -- set Bridge VLAN filtering to yes
    -- added all VLAN-ID's
    -- set physical port "wan" untagged id 1, tagged all other VLAN ID's
    -- set physical port "lan1" untagged id 1
    -- set physical port "lan3" to untagged id 3

But now, when I connect a device to physical port "lan3" I got an IP address from VLAN id 1 range and not from VLAN id 3 range as expected.

/etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option cachesize '1000'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option filter_aaaa '0'
	option filter_a '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'hybrid'
	option ra 'hybrid'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fcc0::/16'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'wan'
	option vlan_filtering '0'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'
	option ip6ifaceid '::5'
	option delegate '0'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '3'
	option name 'br-lan.3'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '4'
	option name 'br-lan.4'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '5'
	option name 'br-lan.5'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '6'
	option name 'br-lan.6'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '7'
	option name 'br-lan.7'

config device
	option type '8021q'
	option ifname 'br-lan'
	option vid '8'
	option name 'br-lan.8'

config interface 'Jail'
	option proto 'none'
	option device 'br-lan.3'
	option delegate '0'

config interface 'Freifunk'
	option proto 'none'
	option device 'br-lan.4'
	option delegate '0'

config interface 'PV'
	option proto 'none'
	option device 'br-lan.6'
	option delegate '0'

config interface 'VoIP'
	option proto 'none'
	option device 'br-lan.7'
	option delegate '0'

config interface 'FF_WAN'
	option proto 'none'
	option device 'br-lan.8'
	option delegate '0'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan4'
	list ports 'wan'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan3'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '4'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '5'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '6'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '7'
	list ports 'wan:t'

config bridge-vlan
	option device 'br-lan'
	option vlan '8'
	list ports 'wan:t'

ubus call system board

{
        "kernel": "6.6.73",
        "hostname": "AP-WDR4900",
        "system": "e500v2",
        "model": "TP-Link TL-WDR4900 v1",
        "board_name": "tplink,tl-wdr4900-v1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0",
                "revision": "r28427-6df0e3d02a",
                "target": "mpc85xx/p1010",
                "description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
                "builddate": "1738624177"
        }
}

It might be easier to follow if you give out some screenshots of you vlan pages in LUCI.

This was not necessary, but should be fine based on what you've got in your configs.

It would also be a good idea to remove the IPv6 related entries from the lan DHCP server config.

Remove the last line below:

Delete all of the 802.1q stanzas:

If VLAN1 is untagged on the lan and wan ports, make it explicit by adding :u*to each port like this:

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:u*'
	list ports 'lan2:u*'
	list ports 'lan4:u*'
	list ports 'wan:u*'

likewise, make sure you do the same on VLAN 3 for port lan3:

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan3:u*'
	list ports 'wan:t'

Edit your lan network interface to use br-lan.1:

config interface 'lan'
	option device 'br-lan.1'
	option proto 'dhcp'
	option ip6ifaceid '::5'
	option delegate '0'

Restart and test again.

@psherman
Kudos to you, Peter.

Main problem, interface lan should belong to br-lan.1 and not to br-lan.
As soon as you do it right, it works ...

Did some cosmetics & enhancements as you described, too.

Changed name of bridge device "br-lan" to "switch". Just to use same naming on GS108Tv3 and WDR4900 devices.
More easy to remember for dumb end-users like me ...

Next step is upgrading my Archer C7V5 AP's now.

Btw
Is it possible to show "port status" in overview also?
Just as it is shown in GS108Tv3 ?

What "port status" are you referring to, specifically? Can you show a screenshot from your GS108Tv3?

Gladly. GS108T v3 with port status

WDR4900 (similar to Archer C7) without "port status" by default :frowning:

You'll find it under Network > Switch because that device (assuming the WDR4900v2) is ath79 which hasn't migrated to DSA.

Only visually (same injection mold case), but very different hardware.

Based on the screenshot, it's the more common v1 - PowerPC (Freescale MPC85xx/ P1014) with AR8327N switch and AR9381+AR9580 wireless. It has migrated to DSA, no swconfig anymore.

Good catch!

Any idea why the port status isn't showing up? AFAIK, it should be on the main status page for DSA devices.

I have no personal experience/ exposure to PowerPC based devices so far, but there are two requirements for the port status to work:

  • DSA
  • /etc/board.json listing the port assignments

I'm not sure if the later is met (and there could be further issues, depending on user configuration and if the swconfig package is still pre-installed (as dead weight?)).

Ok. I have take a look ...

The swconfig package is installed by default @ Archer C7v5 and WDR4900v1.

Archer C7v5

{
        "kernel": "6.6.73",
        "hostname": "AP-AC1750",
        "system": "Qualcomm Atheros QCA956X ver 1 rev 0",
        "model": "TP-Link Archer C7 v5",
        "board_name": "tplink,archer-c7-v5",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0",
                "revision": "r28427-6df0e3d02a",
                "target": "ath79/generic",
                "description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
                "builddate": "1738624177"
        }
}

Archer C7v5 /etc/board.json

{
        "model": {
                "id": "tplink,archer-c7-v5",
                "name": "TP-Link Archer C7 v5"
        },
        "led": {
                "wan": {
                        "name": "WAN",
                        "sysfs": "green:wan",
                        "trigger": "switch0",
                        "type": "switch",
                        "mode": "",
                        "port_mask": "0x02",
                        "speed_mask": ""
                },
                "lan1": {
                        "name": "LAN1",
                        "sysfs": "green:lan1",
                        "trigger": "switch0",
                        "type": "switch",
                        "mode": "",
                        "port_mask": "0x04",
                        "speed_mask": ""
                },
                "lan2": {
                        "name": "LAN2",
                        "sysfs": "green:lan2",
                        "trigger": "switch0",
                        "type": "switch",
                        "mode": "",
                        "port_mask": "0x08",
                        "speed_mask": ""
                },
                "lan3": {
                        "name": "LAN3",
                        "sysfs": "green:lan3",
                        "trigger": "switch0",
                        "type": "switch",
                        "mode": "",
                        "port_mask": "0x10",
                        "speed_mask": ""
                },
                "lan4": {
                        "name": "LAN4",
                        "sysfs": "green:lan4",
                        "trigger": "switch0",
                        "type": "switch",
                        "mode": "",
                        "port_mask": "0x20",
                        "speed_mask": ""
                }
        },
        "switch": {
                "switch0": {
                        "enable": true,
                        "reset": true,
                        "ports": [
                                {
                                        "num": 0,
                                        "device": "eth0",
                                        "need_tag": false,
                                        "want_untag": false
                                },
                                {
                                        "num": 2,
                                        "role": "lan",
                                        "index": 1
                                },
                                {
                                        "num": 3,
                                        "role": "lan",
                                        "index": 2
                                },
                                {
                                        "num": 4,
                                        "role": "lan",
                                        "index": 3
                                },
                                {
                                        "num": 5,
                                        "role": "lan",
                                        "index": 4
                                },
                                {
                                        "num": 1,
                                        "role": "wan"
                                }
                        ],
                        "roles": [
                                {
                                        "role": "lan",
                                        "ports": "2 3 4 5 0t",
                                        "device": "eth0.1"
                                },
                                {
                                        "role": "wan",
                                        "ports": "1 0t",
                                        "device": "eth0.2"
                                }
                        ]
                }
        },
        "network": {
                "lan": {
                        "device": "eth0.1",
                        "protocol": "static"
                },
                "wan": {
                        "device": "eth0.2",
                        "protocol": "dhcp",
                        "macaddr": "98:da:c4:bf:c9:7f"
                }
        },
        "wlan": {
                "phy0": {
                        "path": "pci0000:00/0000:00:00.0",
                        "info": {
                                "antenna_rx": 7,
                                "antenna_tx": 7,
                                "bands": {
                                        "5G": {
                                                "ht": true,
                                                "vht": true,
                                                "max_width": 80,
                                                "modes": [
                                                        "NOHT",
                                                        "HT20",
                                                        "VHT20",
                                                        "HT40",
                                                        "VHT40",
                                                        "VHT80"
                                                ],
                                                "default_channel": 36
                                        }
                                },
                                "radios": [
                                ]
                        }
                },
                "phy1": {
                        "path": "platform/ahb/18100000.wmac",
                        "info": {
                                "antenna_rx": 7,
                                "antenna_tx": 7,
                                "bands": {
                                        "2G": {
                                                "ht": true,
                                                "max_width": 40,
                                                "modes": [
                                                        "NOHT",
                                                        "HT20",
                                                        "HT40"
                                                ],
                                                "default_channel": 1
                                        }
                                },
                                "radios": [
                                ]
                        }
                }
        }
}

WDR4900v1

{
        "kernel": "6.6.73",
        "hostname": "AP-WDR4900",
        "system": "e500v2",
        "model": "TP-Link TL-WDR4900 v1",
        "board_name": "tplink,tl-wdr4900-v1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0",
                "revision": "r28427-6df0e3d02a",
                "target": "mpc85xx/p1010",
                "description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
                "builddate": "1738624177"
        }
}

WDR4900v1 /etc/board.json

{
        "model": {
                "id": "tplink,tl-wdr4900-v1",
                "name": "TP-Link TL-WDR4900 v1"
        },
        "network": {
                "lan": {
                        "ports": [
                                "lan1",
                                "lan2",
                                "lan3",
                                "lan4"
                        ],
                        "protocol": "static"
                },
                "wan": {
                        "device": "wan",
                        "protocol": "dhcp"
                }
        },
        "system": {
                "compat_version": "1.1"
        },
        "wlan": {
                "phy0": {
                        "path": "ffe09000.pcie/pci9000:00/9000:00:00.0/9000:01:00.0",
                        "info": {
                                "antenna_rx": 7,
                                "antenna_tx": 7,
                                "bands": {
                                        "5G": {
                                                "ht": true,
                                                "max_width": 40,
                                                "modes": [
                                                        "NOHT",
                                                        "HT20",
                                                        "HT40"
                                                ],
                                                "default_channel": 36
                                        }
                                },
                                "radios": [
                                ]
                        }
                },
                "phy1": {
                        "path": "ffe0a000.pcie/pcia000:02/a000:02:00.0/a000:03:00.0",
                        "info": {
                                "antenna_rx": 7,
                                "antenna_tx": 7,
                                "bands": {
                                        "2G": {
                                                "ht": true,
                                                "max_width": 40,
                                                "modes": [
                                                        "NOHT",
                                                        "HT20",
                                                        "HT40"
                                                ],
                                                "default_channel": 1
                                        }
                                },
                                "radios": [
                                ]
                        }
                }
        }
}

GS108Tv3

{                                                                                                                                                                                             
        "kernel": "6.6.73",                                                                                                                                                                   
        "hostname": "SW-BUERO-2",                                                                                                                                                             
        "system": "RTL8380",                                                                                                                                                                  
        "model": "Netgear GS108T v3",                                                                                                                                                         
        "board_name": "netgear,gs108t-v3",                                                                                                                                                    
        "rootfs_type": "squashfs",                                                                                                                                                            
        "release": {                                                                                                                                                                          
                "distribution": "OpenWrt",                                                                                                                                                    
                "version": "24.10.0",                                                                                                                                                         
                "revision": "r28427-6df0e3d02a",                                                                                                                                              
                "target": "realtek/rtl838x",                                                                                                                                                  
                "description": "OpenWrt 24.10.0 r28427-6df0e3d02a",                                                                                                                           
                "builddate": "1738624177"                                                                                                                                                     
        }                                                                                                                                                                                     
}

GS108Tv3 /etc/board.json

{
        "model": {
                "id": "netgear,gs108t-v3",
                "name": "Netgear GS108T v3"
        },
        "bridge": {
                "name": "switch",
                "macaddr": "bc:a5:11:9f:a0:6f"
        },
        "network": {
                "lan": {
                        "ports": [
                                "lan1",
                                "lan2",
                                "lan3",
                                "lan4",
                                "lan5",
                                "lan6",
                                "lan7",
                                "lan8"
                        ],
                        "protocol": "static",
                        "macaddr": "bc:a5:11:9f:a0:6f"
                }
        },
        "network_device": {
                "eth0": {
                        "macaddr": "bc:a5:11:9f:a0:6f"
                },
                "lan1": {
                        "macaddr": "bc:a5:11:9f:a0:6f"
                },
                "lan2": {
                        "macaddr": "be:a5:11:9f:a0:70"
                },
                "lan3": {
                        "macaddr": "be:a5:11:9f:a0:71"
                },
                "lan4": {
                        "macaddr": "be:a5:11:9f:a0:72"
                },
                "lan5": {
                        "macaddr": "be:a5:11:9f:a0:73"
                },
                "lan6": {
                        "macaddr": "be:a5:11:9f:a0:74"
                },
                "lan7": {
                        "macaddr": "be:a5:11:9f:a0:75"
                },
                "lan8": {
                        "macaddr": "be:a5:11:9f:a0:76"
                }
        },
        "system": {
                "label_macaddr": "bc:a5:11:9f:a0:6f"
        }
}

There must exist an additional condition.
I played around with the WDR4900 as Dump-AP.
I added WiFi configs and because its a Dump AP, I'm trying to add Informations about DHCP Leases for those devices connected to WiFi of the Dump-AP.

Suddenly the "port status" was shown. Sadly until now I did not know which entry was responsible.

What specifically were you changing/doing here? Two things to note: 1) DHCP lease information shouldn't affect the port status; 2) make sure you do not enable the DHCP server on the bridged AP -- only one DHCP server is allowed on a network.

A Dumb-AP does not show any information about DHCP-Leases and hostnames / ip-addresses for clients that are connected to a Dump-AP by default.

So finally I only copy the /tmp/dhcp.leases and /etc/ethers files from the main router to all Dump-AP's.
On each Dump-AP these copy's are filtered, so that I get only active entry's. The result is stored in /tmp/dhcp.leases and /etc/ethers.

I have removed those files for testing. But "port status" stays alive.

I guess that defining wireless devices results in display of port status.
Will test it ...

Doing a basic copy won't be robust... search the forum for this and you'll find better methods.

Yup.... as expected. I don't know why it was missing, but the DHCP related files are unrelated.

Not sure exactly what you're saying here.

Got it.

On my "test device" packages are version: 25.059.57589~8d7a815
My "production device" I did an update. So it was slightly newer: 25.062.67750~c03591c

So i did this on my "test device":

opkg update
opkg list-upgradable | cut -f 1 -d ' ' | xargs opkg upgrad

Now I'm on 25.066.49116~3182493 on the test device.
And "port status" is shown as expected :slight_smile:

So I guess it was a bug ...

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.

Because my idea was to use same packages as on my "test device", I have build a firmware image from my "test device" device with attended sysupgrade.
This newly generated firmware I had installed on my "production device".

After comparing configuration, but no differences, I have had the idea to compare installed packages. And found, that the initial installation has older versions installed. So I decided to upgrade.
I'm aware that this could go wrong and that I have to start from scratch again ...

If the two devices are identical, the firmware image itself is okay. But don't copy the configs themselves from one to the other because those contain some unit-specific information (mainly MAC addresses) and can cause issues if they are moved from one device to another.

My WDR4900 is working with WiFi and VLANs as expected for some days now.

But WiFi on my Archer C7 v5 isn't working.
I'm able to connect to every defined WiFi i.e. with a Win10 machine.
But I never get an IP address via DHCP. Only this pointless 169.154... address as usual in Windows.
So I decided to use a fixed IP correspondig to the connected VLAN.
But no communication possible.

Then I have connected the laptop with an ethernet cable to physical lan port 3. And hey presto I got the correct IP via DHCP.

So I guess that there is a problem with the combination of WiFi & VLAN.
Help is welcome ...

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option band '5g'
	option channel '44'
	option htmode 'VHT40'
	option cell_density '0'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option band '2g'
	option channel 'auto'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Freifunk'
	option encryption 'none'
	option network 'Freifunk'
	option disabled '1'

config wifi-iface 'wifinet1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Freifunk'
	option encryption 'none'
	option network 'Freifunk'
	option disabled '1'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'R&R'
	option encryption 'sae-mixed'
	option key '###'
	option ieee80211r '1'
	option mobility_domain '9292'
	option ft_over_ds '0'
	option ocv '0'
	option network 'lan'
	option disabled '1'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'R&R'
	option encryption 'sae-mixed'
	option hidden '1'
	option key '###'
	option ieee80211r '1'
	option mobility_domain '9292'
	option ft_over_ds '0'
	option ocv '0'
	option network 'lan'
	option disabled '1'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'R&R-NoT'
	option encryption 'psk'
	option key '###'
	option network 'Jail'
	option disabled '1'

config wifi-iface 'wifinet5'
	option device 'radio1'
	option mode 'ap'
	option ssid 'R&R-PV'
	option encryption 'sae-mixed'
	option key '###'
	option ocv '0'
	option network 'PV'
	option disabled '1'

config wifi-iface 'wifinet6'
	option device 'radio1'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'sae-mixed'
	option key '###'
	option ocv '0'
	option network 'Jail'

config wifi-iface 'wifinet7'
	option device 'radio1'
	option mode 'ap'
	option ssid 'NoVLAN'
	option encryption 'sae-mixed'
	option key '###'
	option network 'lan'
	option ocv '0'

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fcc0::/16'
	option packet_steering '1'

config interface 'lan'
	option device 'eth0.1'
	option proto 'dhcp'
	option delegate '0'
	option ip6ifaceid '::7'
	option type 'bridge'

config device
	option name 'eth0.2'
	option macaddr '98:da:c4:bf:c9:7f'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 1 2 3'
	option vid '1'
	option description 'LAN'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t'
	option vid '2'
	option description 'WAN'

config device
	option type 'bridge'
	option name 'switch'
	list ports 'eth0.1'
	list ports 'eth0.2'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option description 'JAIL'
	option ports '0t 1t 4'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '4'
	option description 'FREIFUNK'
	option ports '0t 1t 5'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '5'
	option description 'FF_MESH'
	option ports '0t 1t'

config switch_vlan
	option device 'switch0'
	option vlan '6'
	option vid '6'
	option description 'PV'
	option ports '0t 1t'

config switch_vlan
	option device 'switch0'
	option vlan '7'
	option vid '7'
	option description 'VOIP'
	option ports '0t 1t'

config switch_vlan
	option device 'switch0'
	option vlan '8'
	option ports '0t 1t'
	option vid '8'
	option description 'FF_WAN'

config interface 'Jail'
	option proto 'none'
	option device 'eth0.3'
	option delegate '0'
	option type 'bridge'

config interface 'Freifunk'
	option proto 'none'
	option device 'eth0.4'
	option delegate '0'

config interface 'PV'
	option proto 'none'
	option device 'eth0.6'
	option delegate '0'
	option type 'bridge'

config interface 'VoiP'
	option proto 'none'
	option device 'eth0.7'
	option delegate '0'

config interface 'FF_WAN'
	option proto 'none'
	option device 'eth0.8'
	option delegate '0'

config interface 'FF_MESH'
	option proto 'none'
	option device 'eth0.5'
	option delegate '0'

config switch_vlan
	option device 'switch0'
	option vlan '9'
	option ports '0t 1t'
	option vid '99'
	option description 'PARACHUTE'

config interface 'Parachute'
	option proto 'static'
	option device 'eth0.99'
	option ipaddr '192.168.99.4'