Need help with setting up a dedicated ip from my isp

Guys, I live in a country atm, where I can't speak the local language, so having the language barrier issues..
Due to the double nat problems, contacted my isp asking them to put my fiber modem into the bridge mode, which they refused but offered to sell me a dedicated ip. So i got it, but still being routed through the modem's nat and my router still gets the local ip of the modem. So double nat issue not solved.
I tried changing dhcp on the router to static with the typical public ip xx.xx.xx.xx netmask gateway xx.xx.xx.0 but that didn't work. So I contacted the isp again, but they are refusing to give any further assistance on that.
Any help very welcome.

P.S. I don't have any access to change the modem gateway settings, can only be managed by the ISP ..

2021-09-05 15_04_11-Command Prompt

You still need to have a router with NAT enabled unless you have only one computer that to which you have the dedicated IP Address assigned. If you want more than one computer attached you have to have them behind NAT or purchase a dedicated IP for each one of them

Router's Nat is no problem, the modem's Nat ( is what's causing the problem for me ..

If i tracert the dedicated ip given me by the ISP, it escapes the modem's nat.
I just don't understand how to set my wan to use the dedicated ip ...

Set WAN on router to static IP, use the IP provided by ISP?

Or isn't it working?

I wasn't given any extra details by the ISP, like netmask, gateway, tried a few different ways, but nothing worked

You can fix the double NAT issue, if you configure the OpenWrt router as a dumb AP. But I guess that is not what you need. You want to have the public IP on the WAN port of your router, and you need to reconfigure the modem for that. Can't you change any configuration on the modem?

The modem is fully managed by the ISP, no http no console access from my side.
I'm open to any solution to solve the double nat issue, I think I know what you mean, but it's not the openwrt's nat what's causing my problem, but the modem's nat, so I guess, it won't work...

Just tried (temporarily) opening the 80 port on the wan side in the firewall settings, I can access the Lede on the dedicated Ip..

Next idea is to pay for an external VPS with a public IP address, and use a VPN from your router.

I have a couple of the vps's, but it doesn't work in my situation. Basically, I need a public ip to be assigned to wan of the openwrt router ..