Need help with OpenWRT "Dumb" Access Point + AdGuardHome (+fritzbox) combo

(Sorry in advance, I'm beginner, go easy on me)

I have managed to set up a "dump AP" with my Netgear WAX206 (AX3200) router (ram 512MB, flash 256MB). Internet works seemingly fine.

My setup:

  • Internet is coming from landlord. I don't have physical access to the main router. IP scan shows me a fritzbox (i'm in germany) on 192.168.178.1 so I assume that is the main router which is connected to a mesh system. One of the range extenders of the mesh system is what I have physical access to (its in my room apartment).
  • My OpenWRT router connected to the range extender via LAN cable, and then creates a new wireless network for myself. The internet and WebUI works, although the network/diagnostics/ipv4 ping says: ping: bad address 'openwrt.org' (screenshot)

My AdGuardHome config screenshots: https://imgur.com/a/y4enGjE
Theoretically running, I can access the WebUI, however it does not block any ads

  • I changed the webUI port to 8080 (which was 80 by default)
  • I changed the default DNS server port to 54 (which was 53 by default)
  • Setup Guide menu says: "AdGuard Home DNS server is listening on the following addresses: 192.168.178.131:54"
  • Comment: I have to manually start AGH after rebooting the router in terminal through ssh with these commands in the openwrt documentation ("service adguardhome enable" and "service adguardhome start")

My OpenWRT config screenshots: https://imgur.com/a/0xGa7Vv

  • I can reach the WebUI over wireless
  • the LAN interface is set to static:
    • I manually configured a IPv4 address (192.168.178.131)
    • netmask 255.255.255.0
    • manually configured a IPv4 gateway that points to the main router (fritzbox)(192.168.178.1)
    • Custom DNS server in the advanced tab is also set to point the main router (192.168.178.1)
  • I configured DNS forwarding in the "DHCP and DNS" settings to "192.168.178.131#54"

On top of that, I tried to set my Macbook Wifi DNS to 192.168.178.131:54 but did not cause any change.

I'm stuck. I can access internet, openwrt and AGH webUI too, but ads not being blocked. Watched several videos and read forums, no luck... I assume its something with the DNS and I read that sometimes this can also depend on the ISP and/or I need to configure something on the fritzbox...

I'm also interested in other adblocking options if I can't make this work. Also, on my phone I just simply have private DNS enabled "dns.adguard.com" and it works relatively good, I can't really comprehend how is that different from running AGH on the router or even just a browser extension...

Let me know what other info I can provide and thank you very much in advance!

My advice would be not to setup as a dumb ap but as a regular router. So reset to defaults and connect the wan port

Which mode in the wireless interface configuration means "regular router"? This is what I see in the Mode dropdown:

I assume I would still need to set a static IP somewhere because the IPs would be distributed by the fritzbox or the main router of the existing mesh system?

If you can point me to which documentation here explains the regular router setup thats also fine as a start. Thanks a lot!

If you are connected by a lan cable to the landlord system the only thing you have to do is reset to defaults and connect to the wan port of your own router.
Then you will have your own subnet and wirelss ap

1 Like