4zims
July 3, 2023, 2:05am
1
Hey everyone,
I keep getting the warning message "No default route present, overriding ra_lifetime!"
I've checked my IPv6 configuration and ensured that my ISP supports IPv6.
Any insights, suggestions, or troubleshooting steps would be greatly appreciated.
Thanks in advance!
root@DLiNK:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd08:2a0b:8e15::/48'
option packet_steering '1'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'wan.500'
option proto 'pppoe'
option username '***'
option password '***'
option ipv6 '1'
config interface 'wan6'
option device '@wan'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
config device
option type '8021q'
option ifname 'wan'
option vid '500'
option name 'wan.500'
root@DLiNK:~# cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
Update to the latest version ;- ) and perhaps one of these is helpful:
opened 03:59PM - 21 Jun 19 UTC
closed 02:38PM - 17 Feb 23 UTC
Implementing #119 with:
```
config dhcp 'lan'
option interface 'lan… '
option dhcpv6 'disabled'
option ra 'server'
option ra_management '0'
option ra_lifetime '1800'
list dns 'fd31:aeb1:48df::2'
option prefix_filter '2001:123:ab:123::/64'
option ra_preference 'medium'
config dhcp 'lan1'
option interface 'lan1'
option dhcpv6 'disabled'
option ra 'server'
option ra_management '0'
option ra_lifetime '1800'
list dns 'fd31:aeb1:48df::2'
option prefix_filter 'fc00:0:0:0:0:0:0:0/7'
option ra_preference 'medium'
```
even with `ra_lifetime` specified (i.e. not expecting default) one of the prefixes is still advertising a lifetime of 0:
```
Soliciting ff02::2 (ff02::2) on pc_bridge...
Hop limit : 64 ( 0x40)
Stateful address conf. : No
Stateful other conf. : No
Mobile home agent : No
Router preference : medium
Neighbor discovery proxy : No
Router lifetime : 0 (0x00000000) seconds
Reachable time : unspecified (0x00000000)
Retransmit time : unspecified (0x00000000)
Source link-layer address: 6C:B0:CE:F5:1E:4A
MTU : 1280 bytes (valid)
Prefix : fd31:aeb1:48df::/64
On-link : Yes
Autonomous address conf.: Yes
Valid time : infinite (0xffffffff)
Pref. time : infinite (0xffffffff)
Route : fd31:aeb1:48df::/48
Route preference : medium
Route lifetime : infinite (0xffffffff)
Recursive DNS server : fd31:aeb1:48df::2
DNS server lifetime : 6000 (0x00001770) seconds
from fe80::6eb0:ceff:fef5:1e4a
Hop limit : 64 ( 0x40)
Stateful address conf. : No
Stateful other conf. : No
Mobile home agent : No
Router preference : medium
Neighbor discovery proxy : No
Router lifetime : 1800 (0x00000708) seconds
Reachable time : unspecified (0x00000000)
Retransmit time : unspecified (0x00000000)
Source link-layer address: 6C:B0:CE:F5:1E:4A
MTU : 1280 bytes (valid)
Prefix : 2001:123:ab:123::/64
On-link : Yes
Autonomous address conf.: Yes
Valid time : infinite (0xffffffff)
Pref. time : infinite (0xffffffff)
Route : 2001:123:ab:123::/64
Route preference : medium
Route lifetime : infinite (0xffffffff)
Recursive DNS server : fd31:aeb1:48df::2
DNS server lifetime : 6000 (0x00001770) seconds
```
Is this a bug? I'm using:
```
# opkg info odhcpd
Package: odhcpd
Version: 1.15-3
_______ ________ __
| |.-----.-----.-----.| | | |.----.| |_
| - || _ | -__| || | | || _|| _|
|_______|| __|_____|__|__||________||__| |____|
|__| W I R E L E S S F R E E D O M
-----------------------------------------------------
OpenWrt 18.06.2, r7676-cddd7b4c77
-----------------------------------------------------
```
opened 12:15AM - 04 Feb 23 UTC
closed 02:37PM - 17 Feb 23 UTC
bug
Hello,
Following on https://github.com/openwrt/odhcpd/issues/133 and since [o… dhcpd](https://github.com/openwrt/odhcpd) says issues should be reported here instead...
### Describe the bug
It seems to be impossible to successfully specify `ra_lifetime` and have it working, even with `ra_default=2` Example config:
````
config dhcp 'lan'
option interface 'lan'
option leasetime '12h'
option dhcpv4 'server'
option start '10'
option limit '100'
option ra 'server'
list dns 'fe80::1:51ff:fe44:a2'
option ra_default '2'
list domain 'lan'
option ra_preference 'high'
option ra_lifetime '1800'
option ra_useleasetime '1'
````
This is what gets logged:
````
$ logread -f
Fri Feb 3 21:44:56 2023 daemon.debug odhcpd[13338]: Using a RA lifetime of 0 seconds on lan
Fri Feb 3 21:44:56 2023 daemon.notice odhcpd[13338]: Sending a RA on lan
Fri Feb 3 21:44:56 2023 daemon.debug odhcpd[13338]: Sent 88 bytes to ff02::1%lan@br-lan
Fri Feb 3 21:45:12 2023 daemon.debug odhcpd[13338]: Using a RA lifetime of 0 seconds on lan
Fri Feb 3 21:45:12 2023 daemon.notice odhcpd[13338]: Sending a RA on lan
Fri Feb 3 21:45:12 2023 daemon.debug odhcpd[13338]: Sent 88 bytes to ff02::1%lan@br-lan
````
With Wireshark I can see those RA's broadcasted:
````
// ip.version == 6 && icmpv6.type == 134
Frame 53090: 142 bytes on wire (1136 bits), 142 bytes captured (1136 bits) on interface en0, id 0
Ethernet II, Src: MS-NLB-PhysServer-xx_xx:xx:00:a2 (xx:xx:xx:xx:00:a2), Dst: IPv6mcast_01 (33:33:00:00:00:01)
Internet Protocol Version 6, Src: fe80::1:---:---:a2, Dst: ff02::1
Internet Control Message Protocol v6
Type: Router Advertisement (134)
Code: 0
Checksum: 0x4911 [correct]
[Checksum Status: Good]
Cur hop limit: 64
**Flags: 0x48, Other configuration, Prf (Default Router Preference): High**
Router lifetime (s): 0
Reachable time (ms): 0
Retrans timer (ms): 0
ICMPv6 Option (Source link-layer address : xx:xx:xx:xx:00:a2)
ICMPv6 Option (MTU : 1500)
**ICMPv6 Option (Recursive DNS Server fe80::1:---:---:a2)**
ICMPv6 Option (DNS Search List Option lan)
ICMPv6 Option (Advertisement Interval : 20000)
````
This seems to be an isolated problem with the lifetime parameter, for instance `ra_reachabletime='1800'` works as expected:

### OpenWrt version
r19803-9a599fee93
### OpenWrt target/subtarget
sunxi/cortexa53
### Device
Any Device
### Image kind
Official downloaded image
### Terms
- [X] I am reporting an issue for OpenWrt, not an unsupported fork.
openwrt:master
← jplitza:patch-1
opened 11:31AM - 04 Jul 19 UTC
The value 0 has the special meaning of not being a default router. This is usefu… l to only advertise prefixes or DNS settings without being a real router.
1 Like
4zims
July 7, 2023, 9:03pm
3
I have ra_default
set to 2
(forced), and the warning is no longer there.
All seems good, right?
Seems so. Please mark the thread as solved!
system
Closed
July 18, 2023, 9:22am
6
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.