Need help with Linksys E4200 V2 Router

ok, not sure if this is the correct... category. anyways..
ok, i'm using a Linksys E4200 V2 Router. mainly using it as a... repeater i guess? Connecting it to a modem/gateway through wifi then this router connects to my devices.
so far everything was working fine for the most part.
was wanting to testing a few things and such then noticed there was an update of openwrt since i was using the OpenWrt 18.06.1 r7258-5eb055306f / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)
so i used the Update firmware located here:
and after updating i finally later noticed that my phone was connected but no internet was going through it. unsure why this was, using 2.4ghz band for the devices since nothing takes it, and using the 5ghz band to connect to the modem. how I've had it setup before updating to 18.06.2. but now I've switched between the... partitions since the 18.06.1 AND the 2 are on here, and both are now doing the same thing. and I've been trying to revert one or both partitions back to factory firmware but i'm not having great luck with that and can't find anything about stripped firmware's for this router and just getting greatly frustrated. so far the internet works on only one device through wifi and that's the amazon firestick my friend is using and my PC which is connected to the router through ethernet. as of now just wanting to switch back to the factory firmware and see if i can get something to work so i don't have to deal with openwrt, other wise i'll just reinstall the 18.06.1 on the second partition like i had it before the update messed everything up.
and no i don't know any of the code for this so if there is help, the easiest way is to pretend i've never touched code and need to be walked through it.

Are you saying that everything works except for one phone?

no, 3 phones.

If your network is IPv4 only, turn off the IPv6 DHCP server (under LAN network settings). Check the status screen on the phone to make sure you have a proper IP address.

talking about on the phone's or the router? pretty much lost me... there is interfaces with lan, wan, wwan and so on with openwrt...

On OpenWrt, go to network -- interfaces, find LAN, click Edit, go to the bottom half of the page, click the IPv6 tab, set all to disabled.

actually did that and no differences. even went into advanced settings and disabled that "Use builtin IPv6-management", tested that with no difference also.

also, in case it's needed to know. pretty much the only thing's I've done right after a reset of the firmware settings. i set up the wifi to connect to the devices, then connect to the modem with both 2.4ghz and 5ghz, with only the 5ghz on the modem right now, then, think that's literally the only things i've done lol.

Is it set up as a conventional routed AP? By that I mean the wifi users (phones) are on a LAN network, and the connection to the Internet (the client radio connected to the other modem / router) is a WAN or WWAN?

yes, i believe so. had to double check lol.
the 5ghz is on wwan5 to the modem, while the wifi on devices are connecting to is on the lan.
in the 2.4ghz for devices in "Interface Configuration">general setup - Network = lan
yeah, thought it was all fine and dandy lol. but only my roomates firestick is the only thing actually using the internet through the wifi for some reason.

1 Like

That seems right. On the main status page you should see a WAN IP has been acquired, and it must be in a different range from the LAN IP.

On the phone, you are saying it has a wifi connection but it has an X or ! over the signal bars, and you have actually checked that there really is no Internet access with a browser?

yeah everything is setup like i had it before with no problems. did that update and switched to the other partition since i thought it was the update and both do it now.
they connect with no problems, only my roommate newer phone shows up as connected but no internet, the others connect and say nothing til you try and load something. why it took me almost a day to notice it since i went to check my messages on my phone then tried to update a couple apps and says no internet lol. right now i'm using the 18.06.1 but can run putty to switch back to the 18.06.2

huh... well not sure how to change that... after you said about the IP i said screw it and made a static IP on my phone since i think the main ip my phone was using was for auto dhcp in the router, and noticed the firestick was using 207 changed my phone to 200 with DNS as and secondary as now it works on my phone. where do i change the dhcp stuff to fix that in openwrt?

The particular IP you use should not matter as long as it is in the LAN network range and not conflicting with another machine. The problem may actually be the DNS. The internal DHCP will set the client to use the OpenWrt router for DNS.

Try the network diagnostic page on the router to see if it can look up and ping a site properly.

1 Like

well, just manually made all the devices with an IP higher than 200 and they all connect fine. was wanting to change the range thing on it so i i didn't have to do the static stuff, but oh well lol.
went to the diagnostics page and it's saying on everything i type in... "ping: bad address ''"
doesn't seem to matter yet i'm using the internet from it on my pc now to write you this lol.

That is a problem-- it means your WAN configuration is incorrect. Ordinarily the WAN would be DHCP client which should pick up the DNS server from the ISP modem. If you have static IP on the WAN side you need to specify a DNS server there.

1 Like

ok, so in the interfaces wwan and wwan5(the two connecting to the modem) i do have a static IP for it to the modem DMZ reasons(even though i don't know how to setup DMZ in openwrt.)
anyways. yeah i just changed the DNS too and the second left it blank since i thought it'd auto set it up. but did that and did a ping and it now pings.

yep, just tested my phone after changing the DNS on the router... go small stupid miss-able stuff... ip is 127 now and still working so that was it apparently...
now i just need to figure out how to get DMZ to work for my PC and also try and get the linksys factory firmware on the other partition lol.

@mk24 thanks for the help on that. glad it wasn't something worse than that.

Can I get a Solved?

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.