Need help with IPV6

I have really been struggling to get IPv6 to work with my configuration as a travel router with openwrt. Here is my current network configuration, it uses TUN0 to allow my vpn to work, but how can I incorporate ipv6?

Essentially what would I have to add to get ipv6 to work wan6? or can I add that to my wwan configuration below?

Thanks for any help.

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd5d:9b19:d663::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '10.82.82.1'
option netmask '255.255.255.0'
option ip6assign '60'
option force_link '1'

config interface 'wwan'
option proto 'dhcp'
option reqprefix 'auto'
option dns '9.9.9.9 149.112.112.112'

config interface 'vpnclient'
option proto 'none'
option device 'tun0'

I was able to get this working by making an alias to wwan via WAN6...

config interface 'WAN6'
option proto 'dhcpv6'
option device '@wwan'
option reqaddress 'try'
option reqprefix 'auto'
option ip6assign '64'

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.