Need help with dual radio WDS

On a wireless repeater I have set Client(WDS) on 2.4ghz radio, I’m trying to enable 5ghz radio on the repeater for wireless connectivity but it doesn’t work.

I have read here using one radio as backhaul and another as AP gives better bandwidth in WDS setup, but it simply doesn’t work.

Please help.

  1. Post your current configuration,
  2. "it does not work" is not very helpful.

Hey Edu, this is my config on the repeater

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option country 'IN'
        option cell_density '0'
        option txpower '12'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option country 'IN'
        option cell_density '0'
        option txpower '18'

config wifi-iface 'wifinet2'
        option device 'radio0'
        option mode 'sta'
        option network 'lan'
        option ssid 'SL-WiFi'
        option bssid 'xx:xx:xx:xx:xx:xx'
        option encryption 'psk2'
        option key '****'
        option wds '1'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option ssid 'SL-WiFi'
        option encryption 'psk2'
        option key '****'
        option network 'lan'
        option ieee80211r '1'
        option mobility_domain '0e39'
        option reassociation_deadline '20000'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

config wifi-iface 'wifinet4'
        option device 'radio0'
        option mode 'ap'
        option ssid 'SL-WiFi'
        option encryption 'psk2'
        option key '****'
        option network 'lan'

cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fddf:7c4d:43aa::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'
        option stp '1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option gateway '192.168.1.1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '0'

config interface 'wwan'
        option proto 'dhcp'

I would first remove the ieee80211r parameters, then restart the wifi and see if there are any relevant messages in the logs. When you say "it does not work", what do you mean exactly?

I want to use 2.4ghz as WDS backhaul and 5ghz for wifi clients, but if I set it up this way the repeater loses its connection to main router. I can’t even access luci after that.

If I use same radio for both backhaul and wifi clients it works.

Could this be a device constraint? It’s a 8/64 device.