Need help with debricking of EA8300

Hi, I had openwrt installed on both partitions of EA8300 and ran the following script.

# This script changes the router to boot from the alternative kernel/partition.

cur_boot_part=`/usr/sbin/fw_printenv -n boot_part`
if [ "$cur_boot_part" = "1" ]
    echo "Switching to kernel/partition 2"
    fw_setenv boot_part 2
    fw_setenv bootcmd "run altnandboot"
elif [ "$cur_boot_part" = "2" ]
    echo "Switching to kernel/partition 1"
    fw_setenv boot_part 1
    fw_setenv bootcmd "run nandboot"
    echo "Error: unexpected value: boot_part=$cur_boot_part"
fw_printenv auto_recovery

The board is bricked now. Linksys led turns on twice and then the hardware becomes unresponsive. I also tried to access serial port as per the link but was not able to.
Any help to debrick the device would be much appreciated. Thanks!

Thanks @tmomas for editing the post. I will take care of text formatting from next time.

fwiw, I presume you tried the Recovery (Automatic) instructions.

Are you sure your serial adapter is working and wired correctly (Tx and Rx not transposed) ? I would have expected uboot to output something to the console even if it could not boot up openwrt.

So far I have tried 30/30/30 reset which did not work. For console, I have used different serial adapters and also tried interchanging TX/RX but no luck.

30/30/30 'ddwrt style' reset does not apply to openwrt devices.

To reset EA8300, turn it on for 2 minutes, then hold Reset button in for 10 seconds with paper clip/pin.

Have you tried Recovery (Automatic) as described in Wiki page?

Unfortunately, if you get nothing from console, it looks like there is a catastrophic failure, but I could be wrong.

I did try the Recovery(Automatic) method. Though it was clearly mentioned that it would work only in case you have flashed openwrt one time and you still have stock firmware in the other partition. In my case both partitions have openwrt. As expected it did not work.