More than one year, I moved home and kept my LinkSys WRT32X route in its box.
Recently, I got a new ISP, took back my router and upgraded from 19.07.10 to
Now I need to set it up.
My home network is
WAN from FFTLA (Fiber To The Last Amplifier) then converter to ethernet connected to the WAN port of my router LinkSys WRT32X, then LAN ports.
I did reading in the OpenWrt Wiki but it's a bit hard for me. I need help to confirm the following
Connection to WAN has a specific port in my router named Internet.
I have only 2 VLAN, first connected to Internet with only 2 devices as said just above. The second is the home LAN with 4 ports in bridge mode.
I don't think I need to tag the traffic (even it was working well with tags in a similar config in my previous install 2 years ago with OpenWrt 19.07.10).
I started to setup as follow
cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fdd3:43ce:a9f4::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'wan'
option macaddr '62:38:e0:ce:80:10'
config interface 'wan'
option device 'wan'
option proto 'static'
option ipaddr '192.168.11.2'
option netmask '255.255.255.252'
option gateway '192.168.11.1'
list dns '149.6.4.187'
list dns '1.1.1.1'
list dns '54.77.119.36'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
option reqaddress 'none'
option reqprefix 'auto'
I noticed that in the v23.05 LuCi interface, there is no "switch" item in the network menu. Is it usual ?
How to set it?
In my readings, I found examples with similar network config, could you point me to the exact same config (it seems basic and common) where I could copy the setting?
The default configuration of OpenWrt will typically bridge all lan ports and separate out the wan port and assign it to the wan interface. So, aside from your static IP configuration on the wan, this is effectively a completely standard/default configuration. And DSA is the same in this regard... a completely default configuration of a DSA device should provide exactly the same functional configuration you have shared (except for the wan by default being dhcp client).
I have not heard it called that but it sounds like they're trying to glorify what is basically cable Internet service. (Most cable systems use fiber for long runs across town, then convert to coaxial segments at the neighborhood level). Is the line into the house a coaxial cable?
The default configuration is intended to work with most cable systems as it is. The cable company will assign an IP via DHCP.
I have a coaxial socket in the wall, connected to a "cable modem" ARRIS CM3200B. This device has a Ethernet port.
Are you sure?
In my previous setting my router had a static address with 255.255.255.252 mask.
I'll try to connect a computer directly to the "cable modem" device and see the IP addresses.
Your cable modem is a modem only, so unless you have a static IP from your ISP the connection protocol is likely DHCP.
(In many cases, even with a static IP from the ISP, they simply provide a static IP via DHCP reservation and they tell customers to configure with DHCP.)
In the US (and likely other places around the world), typically the cable modem will "learn" the MAC address of the connected equipment, meaning that you need to reboot the modem (sometimes a few times) to get it to release the previous binding and learn a new MAC -- keep that in mind when you are plugging in different pieces of equipment.
To @mk24 's point, you really just have glorified cable modem service... that's fine, of course, but they are using fiber as a somewhat misleading marketing ploy. FTTH/FTTP (fiber to the home/premises) is the 'real' fiber service (quality/reliability/speed class aside, this type of service is what most people think of when they hear fiber, and it requires an ONT or other optical media module to operate). Many ISPs these days have fiber running most of the way, but those that don't run FTTH/FTTP will run the last mile with different medium such as coax or DSL, or even wireless. When I ordered AT&T service many years ago, they advertised it as an "all fiber network", but it turns out it was DSL for the last mile which means it was really FTTN (Fiber to the Node). It turned out the service was terrible since it was using antiquated DSL tech.
Your ISP provides you an IP by means of a DHCP lease. You cannot just insert your own IP and subnet mask.
From a default/reset state, you simply connect a cable between your cable modem and your router's WAN port. It's that simple. The router is already configured for use as a DHCP client, which is what your ISP requires. As noted earlier, you'll probably need to reboot your modem (just unplug it from power for a few seconds), but that's it.
Thank you psherman, this is working now.
I did a reset then connected wan and lan.
However I don't have the same setting as in the page Converting to DSA
I can't see anything about switch in Network, only in Overview.
Is is fine about security?
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'xxxx:1703:0da7::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'wan'
option macaddr 'xx:xx:e0:ce:80:10'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'