Need help to setup PPPOE via VLAN ID (DSA migration)

Hi All,
Happy morning and happy weekend.

Since last one week i have gone through many of videos and tutorial about DSA migration.
but still i couldn't setup my pppoe connection on my MI 4a gigabit router.
My isp has vlan id to get connect with internet. bcoz of this i facing issues.
i have tried with wan.159 too. but still no success.
So request to kindly help/suggest me!

Here is my actual SWconfig

i have followed as step as below for DSA







but still unable to success

pls help

Hi

from my point of view, your mistake is that you put LAN and WAN interfaces into same bridge.
why don't try to reset to factory, and simply add VLAN (802.1q) device on WAN port, vlan ID=159
this will be your new WAN159 interface and place PPPoE client on this
you don't need to add any bridge on WAN/WAN159 interface

hello @NPeca75 ,
many Thanks for your response. i have tried that already but getting error as


i guess its need to tag them with wan. so pls suggest.

in my earlier i used to tagged like this

Hi

yes, because it was SWCONFIG
and in SWCONFIG, whole chip is managed az ONE chip
that was a reason that last port (WAN) was tagged directly from SWCONFIG

but now, you are using DSA
and every port is SINGLE port, switch chip is hidden behind DSA driver
again, you don't need any WAN bridge
you don't need bridge/vlan filtering

only

this 802.1q device will tag outgoing packets on WAN port


thanks again. i done everything but still no success. sorry if i miss anything.

Post your /etc/config/network, that's far easier to diagnose than all those screenshots. And searchable, for posterity.

1 Like

Hello @Borromini ,
Many thanks for your response.
here its my config

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option packet_steering '1'
option ula_prefix 'fd31:68zb:ec51::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option proto 'pppoe'
option username 'ft431_sid@ftth.bsnl.in'
option password 'password'
option ipv6 'auto'
option device 'wan.159'

config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'

config device
option name 'pppoe-wan'
option macaddr 'D4:45:39:5D:0D:D5'
option mtu '1460'

config device
option name 'wan.159'
option type '8021q'
option ifname 'wan'
option vid '159'
option mtu '1492'

config device
option name 'eth0'
option mtu '1500'

Use the code tags </> to enclose your config please, for readability. See the buttons at the top of your edit screen.

My ISP requires VLAN 10 on the WAN port. My DSA setup is as follows. Note you should split up your device and interface definition, those are two different configuration entries from 22.03 on.

Device stanza

config device
        option type '8021q'
        option ifname 'p8'
        option vid '10'
        option name 'fiber'

The name line is purely optional/cosmetic here, but it allows me to differentiate in the interface stanza.

Interface stanza

config interface 'wan'                              
        option proto 'pppoe'              
        option username '****@*****'
        option password '*****' 
        option ipv6 '1'                                                 
        option device 'fiber'

Remove your pppoe-wan device entry, I'm not sure where you got that from. It was not present on swconfig either to my knowledge. It's an interface name generated by OpenWrt when setting up the PPPoE session, but transparently; you should not be manipulating it yourself. And do you need to specify the MTU?

1 Like

Thanks again. sorry i missed to use the code. shall i reset and try pls confirm?


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd31:68eb:ec51::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'pppoe'
	option username 'ft431_sid@ftth.bsnl.in'
	option password 'password'
	option ipv6 'auto'
	option device 'wan.159'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config device
	option name 'pppoe-wan'
	option macaddr 'D4:95:38:2D:0D:D5'
	option mtu '1460'

config device
	option name 'wan.159'
	option type '8021q'
	option ifname 'wan'
	option vid '159'
	option mtu '1492'

config device
	option name 'eth0'
	option mtu '1500'


You have a possible clash between interface and device names (both being WAN). I would change your device name (option name). And remove this:

config device
	option name 'pppoe-wan'
	option macaddr 'D4:95:38:2D:0D:D5'
	option mtu '1460'
1 Like

i have reset router and tried again
here its my new config file


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd32:3g93:b4e2::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'pppoe'
	option device 'wan.159'
	option username 'id@ftth.bsnl.in'
	option password 'password'
	option ipv6 'auto'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'


hello @Borromini . Kindly let me know if i have to do any changes on above. sry for the disturbing🤦‍♀️

Setting up PPPoE authentication in OpenWrt is very simple. Reset router settings. Go to interface > Add new interface > PPPoE (wan name interface) > In Device go to the end of the list and enter your VLAN ID (wan.159) and create the interface. After entering your login and password, save the interface and restart the router. IPv6 interface will be created automatically too

DON'T FORGET TO PUT THE INTERFACE ON THE WAN FIREWALL

1 Like

hello @viniribeirossa
Many thanks for your response
i have done as you described. but still i couldn't succeed.




Did i miss anything? sry for keep asking🤦‍♂️

maybe your ISP have fixed MAC for authentication
so, try to clone MAC from your old setup ?

1 Like

I have cloned mac. But no luck. Not sure wer iam lacking.my bad luck

on your screenshot, the MAC for LAN is D4:35:xxxxx
and MAC for WAN/PPPoE is same range D4:35:xxxx
so, my opinion is that you did not clone MAC

1 Like

Means not getting you. Pls help how to do mac clone? I i just copy paste from other device

you have wrote somewhere the old MAC which are used in old setup ?
do you see this MAC in LuCI WAN / PPPoE status on Interfaces screen ?

1 Like

You have multiple WAN interfaces. Please delete them all. Now try to create the PPPoE interface as I taught you.

Delete IPv6 interfaces. If PPPoE authenticates correctly, OpenWrt itself will create an IPv6 interface.

After the whole process, don't forget to restart the router.

1 Like

hello @viniribeirossa thanks again.
as you said i have created the interface after that i put it on wan firewall.
then only it came. if i understand correctly.

or you meant to say delete all interface then create new interface at wan?
like this


this also not working