Need help to set mwan3 settings

Hi guys, i need a little help here to set up mwan3 rules with the best efficiency with an "on the road" router (van life... :).

I have these interfaces configured:

  • WAN
  • 5G Wifi as client
  • 2G Wifi as client
  • RM520N-GL as 4G/5G modem

I would like to configure it like this:

  • wired WAN on the top priority even if it will not be in use very often, likely never.
  • 5G Wifi if available or 2G as fail over (manual connection with the ap is ok for me)
  • Quectel modem as a failover for all of this
  • WAN OR Wifi 5G(or 2G)+Quectel if available with a load balancing to Wifi/Wan for torrents download

I'm not an IT expert but i like to learn stuffs by myself! but i'm stuck here! Can you please correct/modify this config for me?

I inspire my tests with this exemple: https://gist.github.com/braian87b/126f20a920e7aabdd495afc861c2a22c
and code this config:

/etc/network/config

GNU nano 8.0 /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd98:1f8f:e9ab::/48'
option packet_steering '1'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
list ports 'wan'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option device 'wan'
option proto 'dhcp'
option dns_metric '2'
option metric '10'

config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option dns_metric '1'
option metric '5'

config interface 'wifi_2G'
option proto 'dhcp'
option metric '20'
option dns_metric '2'

config interface 'rm_520'
option proto 'modemmanager'
option profile '1'
option autoconnect '1'
option apn 'data.lycamobile.fr'
option auth 'pap'
option username 'lmfr'
option password 'plus'
option iptype 'ipv4'
option loglevel 'ERR'
list dns '1.1.1.1'
list dns '1.0.0.1'
option delegate '0'
option device '/sys/devices/platform/1e1c0000.xhci/usb2/2-1'
option signalrate '5'
option metric '30'

config interface 'wifi_5G'
option proto 'dhcp'
option dns_metric '1'
option metric '15'

/etc/config/mwan3

config globals 'globals'
option enabled '1'

config interface 'wan'
option enabled '1'
list track_ip '1.0.0.1'
list track_ip '1.1.1.1'
list track_ip '208.67.222.222'
list track_ip '208.67.220.220'
option reliability '2'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'

config interface 'wifi_5G'
option enabled '1'
list track_ip '1.1.1.1'
list track_ip '208.67.220.220'
option reliability '1'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'

config interface 'wifi_2G'
option enabled '1'
list track_ip '1.1.1.1'
list track_ip '208.67.220.220'
option reliability '1'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'

config interface 'rm_520'
option enabled '1'
list track_ip '1.1.1.1'
list track_ip '208.67.220.220'
option reliability '1'
option count '1'
option timeout '2'
option interval '5'
option down '3'
option up '8'

config member 'wan_m1_w2'
option interface 'wan'
option metric '1'
option weight '2'

config member 'wan_m1_w3'
option interface 'wan'
option metric '1'
option weight '3'

config member 'wan_m1_w4'
option interface 'wan'
option metric '1'
option weight '4'

config member 'wan_m2_w1'
option interface 'wan'
option metric '2'
option weight '1'

config member 'wifi_5G_m1_w2'
option interface 'wifi_5G'
option metric '1'
option weight '2'

config member 'wifi_5G_m1_w3'
option interface 'wifi_5G'
option metric '1'
option weight '3'

config member 'wifi_5G_m1_w4'
option interface 'wifi_5G'
option metric '1'
option weight '4'

config member 'wifi_5G_m2_w1'
option interface 'wifi_5G'
option metric '2'
option weight '1'

config member 'wifi_2G_m1_w2'
option interface 'wifi_2G'
option metric '1'
option weight '2'

config member 'wifi_2G_m1_w3'
option interface 'wifi_2G'
option metric '1'
option weight '3'

config member 'wifi_2G_m1_w4'
option interface 'wifi_2G'
option metric '1'
option weight '4'

config member 'wifi_2G_m2_w1'
option interface 'wifi_2G'
option metric '2'
option weight '1'

config member 'rm_520_m1_w2'
option interface 'rm_520'
option metric '1'
option weight '2'

config member 'rm_520_m1_w3'
option interface 'rm_520'
option metric '1'
option weight '3'

config member 'rm_520_m1_w4'
option interface 'rm_520'
option metric '1'
option weight '4'

config member 'rm_520_m2_w1'
option interface 'rm_520'
option metric '2'
option weight '1'
config policy 'only_1'
list use_member 'wan_m1_w2'

config policy 'only_2'
list use_member 'wifi_5G_m1_w2'

config policy 'only_3'
list use_member 'wifi_2G_m1_w2'

config policy 'only_4'
list use_member 'rm_520_m1_w2'

config policy 'then_1_4'
list use_member 'wan_m1_w2'
list use_member 'rm_520_m2_w1'

config policy 'then_4_1'
list use_member 'rm_520_m1_w2'
list use_member 'wan_m2_w1'

config policy 'then_2_4'
list use_member 'wifi_5G_m1_w2'
list use_member 'rm_520_m2_w1'

config policy 'then_4_2'
list use_member 'rm_520_m1_w2'
list use_member 'wifi_5G_m2_w1'

config policy 'then_3_4'
list use_member 'wifi_2G_m1_w2'
list use_member 'rm_520_m2_w1'

config policy 'then_4_3'
list use_member 'rm_520_m1_w2'
list use_member 'wifi_2G_m2_w1'

config policy 'more_2_4'
list use_member 'wifi_5G_m1_w4'
list use_member 'rm_520_m1_w3'

config policy 'more_3_4'
list use_member 'wifi_2G_m1_w4'
list use_member 'rm_520_m1_w3'

config policy 'more_1_4'
list use_member 'wan_m1_w4'
list use_member 'rm_520_m1_w3'

config policy 'more_4_2_1'
list use_member 'rm_520_m1_w4'
list use_member 'wifi_5G_m1_w3'
list use_member 'wan_m1_w2'

config policy 'more_1_2_4'
list use_member 'wan_m1_w4'
list use_member 'wifi_5G_m1_w3'
list use_member 'rm_520_m1_w2'

DDNS FailOver

config rule 'noip'
option dest_ip 'checkip.dyndns.com'
option proto 'all'
option sticky '0'
option use_policy 'then_2_4'

config rule 'https'
option sticky '1'
option dest_port '443'
option proto 'tcp'
option use_policy 'more_4_2'

config rule 'default_rule'
option dest_ip '0.0.0.0/0'
option use_policy 'more_2_4'