Need help to install LEDE on TP-Link Archer VR2600v

Hello,
I'm the new one and beck from Germany.
I bought a TP-Link Archer VR2600v, because I read about the LEDE support. The "v"-version includes the DSL-modem. Unfortunately I dont inform me about the installation routine, before I bought this device. Maybe is the installation more easy than I think, but it doesn't work for me.
What did I do?
First: I know about 2 different LEDE packages. The initial installation needs the "factory" package. Updates needs the sysupgrade packages. So I try to install the factory package for VR2600 (without "v") with the TP-Link Router surface "extented --> systemtools --> firmware upgrade", but the router doesn't accept the package.

Would explain someone the installation routine for me?

Thanks, thanks, thanks ! :wink:

This is the firmware for the VR2600v...

https://openwrt.org/toh/views/toh_fwdownload?dataflt[Model*~]=vr2600

Hello jwoods,
thanks for your help, but my description was obvious unclear - I'm sorry, I knew about your link, but there I can donwnload the "upgraded" software ("...sysupgrade.bin) . That requires an initial installation before and I don't get this initial installation.

That is the only firmware file available for the device.

For installation instructions see the git commit which added support for this device:
https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=ae79c41286f0d9a97f2641450240ecac5465677d

It is not possible to flash LEDE via the TP-Link webinterface. The
image need to be signed. The first 0x200 bytes of the image is the
TP-Link header including the signature. The signature is not validated
by the bootloader. The LEDE image is zeroed in this area.

To install LEDE it is necessary to solder a four pin header to JP2.
Connect a serial interface to this header and interrupt the autostart
of kernel. Transfer the sysupgrade image via TFTP and write it to the
serial flash at 0x320000.

Does anyone know if this works on the Archer VR2600 that has just the RJ11 ADSL modem and not the DECT part?

Rather late response but may be useful to those Googling.
I loaded the squash firmware from https://openwrt.org/toh/tp-link/tp-link_archer_vr2600v_v1 and also built some custom firmware using the menuconfig build system, both work fine for me as I have full fibre and use the WAN ethernet connection. DSL port does not work as noted in device page.

1 Like

Thanks for the reply ended up getting WRT32x in end and openwrt'ing that.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.