Need help to flash my Meraki MR33


I read this page tried to flash my Meraki MR33 to openwrt:

When i did the 1th step:run this command:# --write=mr33-uboot.bin
ubuntu PC(installed python、serial and minicom):

"Add images to do an installation via bootloader:
0. open up the MR33 and connect the serial console.

  1. start the 2nd stage bootloader transfer from client pc: --write=mr33-uboot.bin

(The ubootwrite tool will interrupt the boot-process and hence
it needs to listen for cues. If the connection is bad (due to
the low-profile pins), the tool can fail multiple times and in
weird ways. If you are not sure, just use a terminal program
and see what the device is doing there."

I had this questions:
1、What floder can I put the files:""and "mr33-boot.bin";

Could anyone help me? Thanks

to answer your question: anywhere on your workstation.
but you should have a look at the mr33 device page, get the installation package from google drive, and follow the instructions in the provided PDF document.

1 Like

thank you.

i flashed "mr33-u-boot.bin" in my mr33 already;

but i cant uplod "openwrt-18.06.2-ipq40xx-meraki_mr33-squashfs-sysupgrade.bin"by tftp

could you tell me is the tftp sever IP is192.168.1.1??

i can ping 1922.168.1.1 form my ubuntu pc by Ethernet cable,but mr33's uboot cant found this tftp server.

The u-boot display loading costantly ..

are you working with the flashing instructions for the MR33? Point 6 on page 7 tells you to upload the initramfs image (not the sysupgrade file).
the MR33 will listen for the TFTP transfer on
your workstation should have some other IP address on the network. You may want to temporarily disable the firewall on your workstation.

i need to flash my mr33 to openwrt,but it can be upgraded,could anyont tell me is my operation right

thank you so much

pl look the picture QQ%E5%9B%BE%E7%89%8720190728142451

Sysupgrade uses sysupgrade images not initramfs tftpboot images

hi,thanks for your help,but it's still not work...

it's the picture:


I have got MERAKI MR32 which I like to load OPENMRT.
I am not able to fine steps.

I have got USB to TTL serial Cable but not issue how this connect to MR32.If they is some one who can email me the steps on how to do this.

My email is


hi,i got this only:

Is this help you?

Looks like meraki MR32 cant work on openwrt...

Thanks for that

Is they any other software I can put on the Meraki MR32.

Do you have the pin lay out ?
How can I connect ?


This topic is about MR33, not MR32. Please keep it this way.