Need help to convert Turris Omnia config to Wrt32x

hello,

i try to make tv from my isp working without the isp box
i have a Wrt32x who has eth0 and eth1

i found a working configuration but for an Omnia (eth0 eth1 eth2
The solution is to create an interface for the tv player :

/etc/config/network :

config interface 'bbox'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '10.10.2.254/24'
        option gateway '10.10.2.254'
        option delegate '0'
        option ifname 'eth2.100'

/etc/config/dhcp :

config dhcp 'bbox'
        option interface 'bbox'
        option start '100'
        option limit '150'
        option leasetime '12h'
        list dhcp_option '6,194.158.122.10,194.158.122.15' 

has anyome an idea how to apply this to my Wrt32x which is on the lan port 3 ?

my wan is on eth1.100
lan is on eth0.1

and my switch config is

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '100'
	option ports '4t 6t'  # thanks to Mikma for his help

thanks for your help