Need help stripping tl-wr940n v4 (US) stock firmware

Hello, I'm having some problems with my router and need to revert back to the stock firmware. I've tried everything possible, but can't get the firmware to work, including using tftp to no avail. I know I could install the stock firmware if I had a stripped version but can't find anything for version 4.

http://www.friedzombie.com/tplink-stripped-firmware/ has up to v3.

Can anyone please help me? It would be really appreciated. Thank you.

I don't know what tftp approach you used, but try this tutorial, which works for several TP-Link routers -

Rename the stock firmware wr940v4_tp_recovery.bin

Common issues I see when it doesn't work...

  1. TFTP server running on the attached computer does not have permissions through the firewall.

  2. Router not powered off first.

  3. Reset button not held in for at least 10 seconds after the router is powered on.

In looking at the specs on wikidevi, the only difference between the v3 and v4 is that the v3 has a 12V DC/1 Amp external power supply, and the v4 has a 9V DC/.6 Amp.

Okay, thanks, let me give that a try. It's been awhile, but whenever I did it the firmware never sent or flashed. I keep thinking maybe it's the filename.

Also, does it matter that my router is 192.168.1.1 instead of 192.168.0.1?

Should I still change it to the ip listed in the tutorial?

Thanks!

I have never changed the IP of the router.

Diff of wikidevi specs...

WR940N_v3_v4

Thanks for your response, but still no luck.

I tried it a few times, and actually got something in the log viewer once. It said

"error 2 in system call CreateFile The system cannot find the file specified". Tried several times, with the power off, with the file in the correct directory, but no luck. Very confusing.

Just to confirm, the file was in the same directory as the TFTP program...

Correct. For some reason this model does not want to cooperate with tftp.

Some TP-Link routers don't have that capability.

Since the chipsets for the version 3 are identical to the version 4, you might consider flashing the FriedZombie v3 firmware.

At this point, your next step is likely a serial flash anyway.