Need help setting up WireGuard on a router connected to a Fiber modem by wire

I am sharing the Fiber modem with my neighbor whose home is too far away to set up wireless connections between us. I have run a Cat 5 ethernet cable between our homes and in a wired bridge connection we share the bandwidth.

What I want to do is setup WireGuard on my NETGEAR Nighthawk (R7200) router which I have upgraded to OpenWrt Version 23.05.0-rc3. I have installed luci-proto-wireguard on the router in my home which again is wired to the Fiber Modem next door. The connection without WireGuard works well and has for several years but when I try to activate wireguard ,which is through SurfShark, I still connect to the internet but wireguard is in active and when I test my connection through SurfShark it verifies that I’m not running any VPN protection through the router.

My thought is that I need to set up a separate DHCP network on the second router. I hope I don’t need to do this because my neighbor and I share a DLNA setup for accessing a Media server, Emby to be more specific. I am aware that he can still access Emby through the internet, but the picture quality is much better by staying on the one local network.

The Fiber Modem is listed below.

Name of Fiber Modem

Giga Hub

Firmware version:

1.16.5

Rescue version:

SGC830007C

User interface version:

7.3.28

Hardware version:

5690-000001-000

Once again, the router that is connected to the Fiber Modem is a NETGEAR Nighthawk (R7200) running OpenWrt. DHCP on the router is disabled and has a static IP. The Local network is 192.168.2.0/24,

Do I need to set up a Subnet or set up a VLAN? I would Like to stay with the adage K.I.S.S (keep it simple stupid) I am hoping that someone has set up a similar home network with WireGuard and can provide some direction.

Cheers