Need help poiting SSID to DSA VLAN

In DSA, all LAN ports are grouped into a bridge by default:

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

I have a VLAN (vid 1) running on the br-lan bridge like this:

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1:t'
	list ports 'lan2:t'
	list ports 'lan3:t'

Can someone give me example config to point an SSID in /etc/config/wireless to this VLAN? The device being configured is an Access Point and its CPU does not need any interface facing this VLAN (option proto 'none').

1 Like

Hi

if i get you right, you are looking for something similar

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option network 'lan100'
        option ssid 'guest'
        option encryption 'psk2+aes'

"option network" is what you need to pair SSID & network

I am afraid it won't work. The config wifi-iface must point to a config interface section (layer-3), whose underlying layer-2 must be a bridge. The wireless interface wifinet1 will become a member interface of the bridge, so that packet can travel to the vlan interface br-lan.1 (or eth0.1 or whatever).

With such configuration:

config interface 'lan100'
	option device 'br-lan.1'
	option proto 'none'

I do not think it will work, because br-lan is a bridge, but br-lan.1@br-lan is not.

First, start with this

it could not be "t" tagged on ports
i don;t think you wanted tagged vlan1 on LAN ports

try something like this

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'
        list ports 'lan2:u*'
        list ports 'lan3:u*'

config interface 'lan'
        option device 'br-lan.1'
        option proto 'none'

then. you could use 'lan' in /etc/config/wireless

You do need to setup a network interface stanza with proto none and device br-lan.1. Then, in the wireless config file, point the new ssid to use the network with proto none.

2 Likes

Yes your bridge-vlan can be associated with a layer 3 network through the syntax bridgename.vlannumber like this:

config interface 'vlan1'
    option device 'br-lan.1'
    option proto 'none'

Here there aren't actually any layer 3 operations, but the UCI system needs this as a stub to properly set up the bridge and have a name that can be used in /etc/config/wireless.

Then in /etc/config/wireless, use option network 'vlan1' in one or more AP mode wifi-ifaces.