Need help please, OpenVPN tun0 wont work :/

Hi,

I've followed every step, except the feed adding part, mentioned in the following tut:

I know its written for openwrt but I like this fork more and also tried it with the mentioned openwrt version which also wont work.

When I've configured everything I click in Luci on /Services/OpenVPN/ start the page loads a second but nothing else happens. The vpn isnt started and also there isnt a tun0 device when I run ifconfig.

Maybe here is somebody who can give me hint to get this to work.

Many thanks!

You may want to try from this wiki. Configurations in here are pretty optimized :grin: I'm currently very satisfy with it :grin:
https://wiki.openwrt.org/doc/howto/openvpn-streamlined-server-setup

Thank you, I'll give this a try.

[Edit]

Maybe I lack of the right knowledge but the linked tutorial is about how to create a server, correct me if I'm wrong.
This isnt what I want. I want to connect to a existing server as a client.

Oh, I'm very sorry for my misunderstanding :confounded:
You should follow this article. On every config just choose client tab :grin:
https://wiki.openwrt.org/doc/howto/vpn.openvpn#configure_the_network_on_the_openwrt_router

1 Like

No problem and thanks again :slight_smile:

I looked at this tutorial but its mostly the same like the one I've linked and that one is about the service I want to use. The only thing that confuses me a little bit is that some tutorials mention a special *.opvn file in which should be the configuration.

Correct me please if I'm wrong but I thought the 'openvpn-openssl' package from OpenWRT/LEDE uses '/etc/config/openvpn' for its configuration so for what is the '*.ovpn' file needed? Isnt it only for other linux distributions i.e. like ubuntu/debian?

With the openvpn package installed you have two choices:

  • you can either use LEDE's /etc/config/openvpn wich is the non-stanardard, UCI-based configuration
  • or you place a vanilla OpenVPN configuration into /etc/openvpn/*.conf and LEDE will take care of starting one OpenVPN instance per *.conf file
1 Like

Okay, so I'll give it a try with the '/etc/openvpn/*.conf' file. But just for clarification, if I followed the tutorial which I linked shouldnt be start a tun0 device if I use ifup/ifconfig tun0 up?

If you couldn't done yet you could try:

I wrote some time ago, many people thank to me since they had no problems following those steps.

It was written for Streisand end but it is almost the same steps for any other VPN provider. Let me know if it was helpful.

1 Like

Hi,

I haven't had time yet but I'll surely will try it.

Thanks