Need help for WAP with 21.02

I need some help configuring a wireless access point with OpenWrt 21.02. I have a Ubiquiti UniFi 6 Lite that I flashed successfully with the 21.02 release (followed https://openwrt.org/toh/ubiquiti/unifi6lite). I want to connect the WAP to a router running pfSense 2.5.2. I have followed the OpenWrt instructions for a "Dumb" Access Point (https://openwrt.org/docs/guide-user/network/wifi/dumbap). Thus far, I have only followed the LUCI instructions. I have two problems when I do so. First, there is no "Physical Settings" tab referred to in Step 6; so after some searching I went to Network -> Interfaces -> Devices to ensure both eth0 and lan are ticked. Second, and probably more importantly, after I "Save-and-Apply" followed by a hard-restart the router (Step 8), the UniFi 6 Lite comes up and none of the settings I did from 1 through 6 is saved. The only modification that makes it through the reset is that firewall, dnsmasq, and ohcpd are not started (step 7). I have decided not to try the command line tools on that page simply for fear something is out of date on the instructions.

I've searched around to find other instructions on setting up a WAP however I ended up in pretty much the same spot. There is a forum post where @psql30 makes it work as a WAP (Unifi 6 Lite + Intel AX210 = No Wifi6), so I know this can be done.

Any help is appreciated!
Thanks

I thought I'd respond to my own message here... I'm getting pretty frustrated, although I have OpenWrt 21.02 flashed successfully to my Ubiquiti UniFi 6 Lite, I cannot get it configured as a wiress access point. Any pointers? I need help.

There are a few other threads about the U6 devices. Have you checked those to see if they will help you solve the issues?

Failing that…

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

@psherman Thanks for responding. Yes, I looked at a few other threads but did not find a solution. I admit my problem may largely be my own ignorance so I do appreciate the help; I am relying heavily on the the GUI instructions for a "Dumb" Access point (https://openwrt.org/docs/guide-user/network/wifi/dumbap). After following those instructions and reconnecting to the WAP, here are the files you asked for. It appears none of the changes I make, except for disabling firewall, dnsmasq, and ohcpd from startup, stick.

Thanks for any advice you have.

root@OpenWrt:/etc/config# cat network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd1f:6052:c1f4::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

root@OpenWrt:/etc/config#
root@OpenWrt:/etc/config# cat wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option htmode 'HT20'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid <REDACTED>
	option encryption 'psk2'
	option key <REDACTED>

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid <REDACTED>
	option encryption 'psk2'
	option key <REDACTED>

root@OpenWrt:/etc/config#
 root@OpenWrt:/etc/config# cat dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

root@OpenWrt:/etc/config#
root@OpenWrt:/etc/config# cat firewall
config defaults
	option syn_flood	1
	option input		ACCEPT
	option output		ACCEPT
	option forward		REJECT
# Uncomment this line to disable ipv6 rules
#	option disable_ipv6	1

config zone
	option name		lan
	list   network		'lan'
	option input		ACCEPT
	option output		ACCEPT
	option forward		ACCEPT

config zone
	option name		wan
	list   network		'wan'
	list   network		'wan6'
	option input		REJECT
	option output		ACCEPT
	option forward		REJECT
	option masq		1
	option mtu_fix		1

config forwarding
	option src		lan
	option dest		wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
	option name		Allow-DHCP-Renew
	option src		wan
	option proto		udp
	option dest_port	68
	option target		ACCEPT
	option family		ipv4

# Allow IPv4 ping
config rule
	option name		Allow-Ping
	option src		wan
	option proto		icmp
	option icmp_type	echo-request
	option family		ipv4
	option target		ACCEPT

config rule
	option name		Allow-IGMP
	option src		wan
	option proto		igmp
	option family		ipv4
	option target		ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/10381
config rule
	option name		Allow-DHCPv6
	option src		wan
	option proto		udp
	option src_ip		fc00::/6
	option dest_ip		fc00::/6
	option dest_port	546
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-MLD
	option src		wan
	option proto		icmp
	option src_ip		fe80::/10
	list icmp_type		'130/0'
	list icmp_type		'131/0'
	list icmp_type		'132/0'
	list icmp_type		'143/0'
	option family		ipv6
	option target		ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Input
	option src		wan
	option proto	icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	list icmp_type		router-solicitation
	list icmp_type		neighbour-solicitation
	list icmp_type		router-advertisement
	list icmp_type		neighbour-advertisement
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
	option name		Allow-ICMPv6-Forward
	option src		wan
	option dest		*
	option proto		icmp
	list icmp_type		echo-request
	list icmp_type		echo-reply
	list icmp_type		destination-unreachable
	list icmp_type		packet-too-big
	list icmp_type		time-exceeded
	list icmp_type		bad-header
	list icmp_type		unknown-header-type
	option limit		1000/sec
	option family		ipv6
	option target		ACCEPT

config rule
	option name		Allow-IPSec-ESP
	option src		wan
	option dest		lan
	option proto		esp
	option target		ACCEPT

config rule
	option name		Allow-ISAKMP
	option src		wan
	option dest		lan
	option dest_port	500
	option proto		udp
	option target		ACCEPT

# allow interoperability with traceroute classic
# note that traceroute uses a fixed port range, and depends on getting
# back ICMP Unreachables.  if we're operating in DROP mode, it won't
# work so we explicitly REJECT packets on these ports.
config rule
	option name		Support-UDP-Traceroute
	option src		wan
	option dest_port	33434:33689
	option proto		udp
	option family		ipv4
	option target		REJECT
	option enabled		false

# include a file with users custom iptables rules
config include
	option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option dest		wan
#	option proto	tcp
#	option target	REJECT

# block a specific mac on wan
#config rule
#	option dest		wan
#	option src_mac	00:11:22:33:44:66
#	option target	REJECT

# block incoming ICMP traffic on a zone
#config rule
#	option src		lan
#	option proto	ICMP
#	option target	DROP

# port redirect port coming in on wan to lan
#config redirect
#	option src			wan
#	option src_dport	80
#	option dest			lan
#	option dest_ip		192.168.16.235
#	option dest_port	80
#	option proto		tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#	option src		wan
#	option src_dport	22001
#	option dest		lan
#	option dest_port	22
#	option proto		tcp

### FULL CONFIG SECTIONS
#config rule
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port	80
#	option dest		wan
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
#	option target	REJECT

#config redirect
#	option src		lan
#	option src_ip	192.168.45.2
#	option src_mac	00:11:22:33:44:55
#	option src_port		1024
#	option src_dport	80
#	option dest_ip	194.25.2.129
#	option dest_port	120
#	option proto	tcp
root@OpenWrt:/etc/config#

This looks pretty much stock in terms of the configuration. In other words, it doesn't look like you've done anything to configure this as a dumb ap.

You usually need to change the IP address -- if your router is using 192.168.1.1, the current setting would directly conflict. You will also want to disable (ignore) the DHCP server on the br-LAN interface.

You might want to check out this solution for similar problem.

Yea, as part of the dumb ap instructions (https://openwrt.org/docs/guide-user/network/wifi/dumbap), I change the ip address, ignore the DHCP server on the br-LAN interface, and a few other things. But none of the changes are permanent; on reboot everything goes back to stock. It is very frustrating. I'll see if I can make the solution you posted work.

I could go back to the Ubiquiti stock firmware, but I'd much rather make OpenWrt work. I ran OpenWrt on a Linksys WRT1900ACS as a router very successfully for a few years.... I'm surprised I am having so many troubles this time around for a wireless access point.

Might be a stupid question, but just double-checking you clicked 'Save & Apply' and not 'Save'?
screenshot

I did have initial issues as per @psherman's post above, but it's all sorted now and my 2 APs are working better vs UniFi stock firmware.

Also keep in mind that the configuration can also automatically roll back when making changes via luci if the browser doesn’t reconnect within a timeout period.

1 Like

@475buhkH Heh, yep, I am definitely hitting "Save & Apply." :slight_smile: Admittedly, I am encouraged to keep going as you have positive results and are happier with OpenWrt versus the UniFi stock firmware.

@psherman Um, thank you. This automatic roll back is something I did not know about. I am changing the IP address after all, so the browser actually does not reconnect within the timeout period. Perhaps this is the source of my struggles! I will try again today.

When making interface changes (Static / DHCP client / etc), wait until it's counted down to about 83 seconds or so, then pull the PoE Ethernet cable, wait 2 seconds, and plug it in again. That's been working for me.

Thanks! It was the rollback that was a problem, and you two helped me sort that out.

I do have one more question. On the guide for setting up a dumb ap (https://openwrt.org/docs/guide-user/network/wifi/dumbap) there is step

  1. Under “Physical Settings” tab, ensure “Bridge interfaces” is ticked, and ensure BOTH of your interfaces (eth0, wlan0) are selected, in order to allow traffic between wireless and wired connections."

There is no more physical settings tab, so I went to network->interfaces->devices and configured the br-lan device such that both eth0 and lan are selected for Bridge ports, see below, where originally only lan was selected in the default. Do I do this correctly?

Thanks again.

Yup. Br-lan should contain the Ethernet port eth0 and the lan network device.

Thanks to both of you for helping out. Cheers.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.