Need Help for setting up NTFS USB Drive using SMB for Windows usage

I'm have 0 experience about this and I already tried to follow but I still can't access it via explorer inside windows 10 (don't have permission to \OpenWRT\Share) the hardware is Linksys EA6350 v3

the drive already mounted on /mnt/sda1 and shared with browseable and allow guests checked. How can I fix it?

For Windows & Samba

Program & functionnalities
Add Support SMB 1.0 /CIFS

I already did that, and the one that installed is SMB v3

shared : USB -> /mnt/sda1

Test with this in your explorer:

\ \\USB ( if mounted on USB )


should be enough to browse it.
double backslashes - the forum filters the input ...

I generally think Samba is a PITA to get to work, I'd rather use cifs.

usb drive directory name is shared and the path is /mnt/sda1 and my router address is
I can't go to \\\shared using explorer because it says I don't have permission to access it.
What should I do to find out what's wrong with the smb/ntfs sharing configuration?

So cifs will be better/easier to setup?
which tutorial is good enough for a total beginnner like me? because when I googled "how to share ntfs usb drive on openwrt" and the result is all about smb

yeah, samba is the general go to solution for windows file sharing, but it isn't very easy to get to work.

your /etc/samba/smb.conf should have entry like this :

comment = usbs public storage 
path = /media/usb
browsable = yes
writable = yes
read only = no
guest ok = yes

You will need to change the path to your mount point /mnt/sda1

:edit: just realised I'm using full samba on ubuntu and not openwrt samba. but samba options should be similar.

I'm sorry, I'm total new to this kind of thing, how can I access the smb.conf file? and how to edit it?

Login to the router with SSH as user root. Then use an editor (default is vi) to edit the file vi /etc/samba/smb.conf

Check this section of the docs especially the "Editing files" which also offers alternative editors.

thanks for your guide

        comment = usbs public storage
        path = /mnt/sda1
        read only = no
        guest ok = yes
        browseable = yes
        writeable = yes

I wrote that and still doesn't work, windows explorer still can't open it

Did you restarted the Samba Service?

yes, I rebooted the router then /etc/init.d/samba enable and /etc/init.d/samba start

If you login to the router what does smbclient -L localhost gives you?

it's give me this

-ash: smbclient: not found

I tried this, the shared folder doesn't even show itself on explorer

Sorry need to install
opkg install samba36-client

installed it and restarted the samba service, the result still same:

these are my screenshots for samba:

and these are when I tried ksmbd: