Need help for isp connection / IPTV configuration

Hello,
i try to connect to my isp without the box provide by it
i have a wrt3200acm router with lede 18.06

the internet connection work but i don't have iptv

i find a working configuration for an usg router internet + tv on a forum but i have not the knowledge to convert it for an Openwrt router.
specially for the route option of the network and for the firewall settings

Can someone help me with this ?

(on this usg's configuration eth0 is the wan and eth1 is the lan - the opposite of my router)

{
        "firewall": {
                "source-validation": "disable",
                "name": {
                        "WAN_IN": {
                                "rule": {
                                        "5": {
                                                "action": "accept",
                                                "description": "Allow Multicast",
                                                "destination": {
                                                        "address": "224.0.0.0/4"
                                                }
                                        },
                                        "20": {
                                                "action": "accept",
                                                "description": "Allow UDP to Multicast",
                                                "destination": {
                                                        "address": "224.0.0.0/4"
                                                },
                                                "protocol": "udp",
                                                "state": {
                                                        "new": "enable"
                                                }
                                        },
                                        "30": {
                                                "action": "accept",
                                                "description": "Allow IGMP",
                                                "protocol": "igmp"
                                        }
                                }
                        },
                        "WAN_LOCAL": {
                                "rule": {
                                        "5": {
                                                "action": "accept",
                                                "description": "Allow Multicast",
                                                "destination": {
                                                        "address": "224.0.0.0/4"
                                                }
                                        },
                                        "30": {
                                                "action": "accept",
                                                "description": "Allow IGMP",
                                                "protocol": "igmp"
                                        }
                                }
                        }
                }
        },
        "interfaces": {
                "ethernet": {
                        "eth0": {
                                "vif": {
                                        "100": {
                                                "dhcp-options": {
                                                        "client-option": [
                                                                "send vendor-class-identifier "BYGTELIAD";"
                                                        ],
                                                        "default-route": "update",
                                                        "default-route-distance": "210",
                                                        "name-server": "update"
                                                }
                                        }
                                }
                        }
                }
        },
        "protocols": {
                "igmp-proxy": {
                        "disable-quickleave": "''",
                        "interface": {
                                "eth0": {
                                        "role": "disabled",
                                        "threshold": "1"
                                },
                                "eth0.100": {
                                        "alt-subnet": [
                                                "0.0.0.0/0"
                                        ],
                                        "role": "upstream",
                                        "threshold": "1"
                                },
                                "eth1": {
                                        "alt-subnet": [
                                                "0.0.0.0/0"
                                        ],
                                        "role": "downstream",
                                        "threshold": "1"
                                },
                                "eth2": {
                                        "role": "disabled",
                                        "threshold": "1"
                                }
                        }
                }
        }
}

thanks a lot

For IPTV Install igmpproxy

https://wiki.openwrt.org/doc/howto/udp_multicast

Use tcpdump on the outside interface to determine the multicast address. Then list the multicast address in the upstream configuration of /etc/config/igmpproxy.

Due to kernel updates/improvements, I don't believe igmp snooping is needed anymore unless on 3.x or older.

1 Like

Actually i have some channels the other i have a black screen with an error signal (f3411, it s a error code from my isp)
my settings are
igmp

config igmpproxy
	option quickleave 0
#	option verbose [0-2]

config phyint
	option network wan
	option direction upstream
        list altnet "0.0.0.0/0"
                

config phyint
	option network lan
	option direction downstream
        list altnet "0.0.0.0/0"

firewall (igmp part)

config rule
	option src 'wan'
	option proto 'udp'
	option dest_ip '224.0.0.0/4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP2'
	option src 'wan'
	option proto 'udp'
	option dest 'lan'
	option dest_ip '224.0.0.0/4'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'
	option dest 'lan'

i did a wireshark but i have a beginners questions :

the multicast adress is the source colon (obviously..) and in the destination colonn i have adress on this type :

232.0.4.3 . Is there somethings to change on firewall's rules ?

multicast5

The firewall rule isn't going to be nearly as complex looking as usg.

The fist thing needing to be done is to find out the IP's.

SSH to the router and run the following command. Let it run for a while and you should see what IP's are in play.

tcpdump -nni eth0 |grep igmp

Once you have your IP's, from LuCi gui go into the firewall settings and create a new "Forward Rule". Give it a name. Set the from interface as Wan, and set the destination as LAN. Set the protocol to igmp, and source IP and destination IP. Don't forget to save and enable the rule.

For your igmpproxy configuration... I don't recommend just setting it to 0.0.0.0. Set as many "list altnet" as you need for upstream, and then set the downstream to a specific IP or your LAN subnet.

I'm not 100% that this is required anymore, but set the following line in the /etc/config/network file.
option igmp_snooping '1'

Put that line in the "config interface LAN".