Need help for isp configuration - vlan

Hello,

i try to connect directly an wrt32x with DavidC snapshot without the isp's modem (bouygues telecom france)

a working configuration for a WRT160NL (found on the net) :

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'

config interface 'wan'
	option proto 'dhcp'
	option delegate '0'
	option ifname 'eth1.100'
	option vendorid 'BYGTELIAD'
	option macaddr 'xx:xx:xx:xx:xx:xx'
	option igmp_snooping "1"

config interface 'wan6'
	option ifname 'eth1'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 4'

i can't find how to adapt this to my wrt32x (vlan etc.. etc...)
i have problem with the wan, vlan, eth port ( lan switch configuration ?)

in fact i'm complety lost

my actuel configuration (modem - wrt32x - dhcp)

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ifname 'eth0.1 tap0'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'static'
	option ipaddr '192.168.3.93'
	option netmask '255.255.255.0'
	option gateway '192.168.3.254'
	option dns '1.1.1.1 1.0.0.1 9.9.9.9'

config interface 'wan6'
	option ifname 'eth1.2'
	option proto 'dhcpv6'
	option auto '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

can someome help me ?

thanks

If you want the wan to be tagged with VLAN 100 then you need to use VLAN 100 instead of VLAN 2 in the switch and tag the port.

1 Like

thanks for your quick answer and explanation mikma

i wil try this

It works

thanks you

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.