Need help compiling firmware

I am trying to compile some oem router firmware from source. The router is the Comtrend CT-5374. It's ancient and every time I try to compile with the make file it says that my kernel is outdated but I am running Ubuntu and my kernel version is 5.6.

It's somewhat unrelated to OpenWRT but I felt like this was the best place to ask because you guys mess with this stuff all the time. Sorry I am a noob with this stuff.

if you use make -j1 V=s you get a more detailed log what is going on, especially on the end.

Without a good log its hard to figure out why it would fail, it could be just a feed dependency, or missing workpath variable for python or indeed a missing apt package.

Which version of Ubuntu are you using? 23.4?

A to old version of Ubuntu can only have to low version of make or cmake and probably other packages aswell, wheres often a higher version of a package is expected to be backwards compatible.

And are you using it in a WSL environment in windows?

If WSL there is one thing you have to change in WSL itself see:

@drowningblue Ideally you set up an old Ubuntu environment, from the time your SDK was produced. Recent build environments typically throw lots of errors. Mind you what you're trying to build is an OEM monstrosity and not OpenWrt, so you're on your own more or less for this kind of thing.

I used Ubuntu server 22.04 LTS with a 5.15 kernel. This is my main server I run my docker stuff on and it is headless. This is the error I get:

make version is GNU Make 4.3
/bin/sh: 1: [: GNU: unexpected operator
kernel version is 5.15.0-70-generic
ERROR: You must use a relatively recent Linux distribution
ERROR: with a 2.6 kernel to build the image!!
make: *** [/opt/bcm963xx_router/make.common:779: kernel_version_check] Error 1

Then I installed CentOS with a 2.6 kernel within the virtual machine same error. I commented out the kernel check in the make file and it started to complile but failed when it got to the kernel.
I have the source files as well.

Thanks everyone for your tips, I got it to build. Used Ubuntu 10.4 i386.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.