Need help bypassing ISP blocks with AdGuard Home on OpenWrt

Hi everyone,

I'm running OpenWRT on my Raspberry Pi 4B and have AdGuard Home installed. Unfortunately, my ISP is blocking access to Imgur and a few other sites, and I've been having trouble finding a solution to bypass the block.

I tried using https-dns-proxy, but it didn't seem to work for me. I'm reluctant to use a VPN, as my isp provides lancache.

Can anyone recommend a solution for bypassing these blocks that works well with AdGuard Home and OpenWRT? Any help would be greatly appreciated. Thank you!

do they block/intercept external DNSes, or is the filter only applied to their own DNS ?

how can i find out?

Try using or as your dns.

doesn't work. dns leak tests show im using google/cloudflare dns but the sites wont load.

edit 1: i did flush dns cache and tried from a different device.
edit 2: browsers say the connection has timed out.

Then your isp isn’t using dns blocking, they’re blocking the service ip addresses or using Deep packet inspection.

Have you asked why they are blocking innocuous sites like imgur?

Are you sure it’s the isp and not your government?

it probably is the government.
so how do i get around this?

VPN or a proxy outside your country.

1 Like

okay. is there a way to only use proxy/vpn for the blocked sites?

Did you try to enable DoH in your browser ?

Theoretically, sure, but you’re on your own

1 Like

yes. didnt work.