Need full dump - TP Link Archer VR2600 installation

Hey, any luck getting the full dump?

Good that you reminded me, I just need to upload it.

1 Like

@biangbiangmian Here is the whole flash dump of my device with factory reset stock firmware.

1 Like

Hey, do you happen to know which chip is the main flash? Tried flashing to one on the back but flashrom said it's the wrong size. Is the one I'm after under the heatsink?

flashrom  on Linux 5.4.0-12-generic (x86_64)
flashrom is free software, get the source code at

Using clock_gettime for delay loops (clk_id: 1, resolution: 1ns).
Found Winbond flash chip "W25Q64.V" (8192 kB, SPI) on ch341a_spi.
Error: Image size (16777216 B) doesn't match the flash chip's size (8388608 B)!

Search for W25Q128 on the chip, it should be the only one with 16MB of capacity.
That 8MB one is for the BCM firmware

1 Like

Found it, but the problem was I only have the 8 pin flasher. Do I need the 16 pin one to flash that chip?

Yes, you need to get a adaptor board.
You got a CH341A one or?

Yeah it's the CH341A, this one. it might be the wrong kind thought, since it says the 25 series chips are not writable?

If its CH341A based, then it will work on all SPI-NOR flash since they all use the standard instructions.
Simply use flashrom and it will work, I have used it on all kinds of SPI-NOR.
You need to use the adapter board to 16 pins and solder the SPI-NOR there

1 Like

Did you ever get the tftp working? And did you ever get openwrt installed? I have a vr2600 not (v) and would like to use it as a proper router.

Hi all. I also have a VR2600 (non -v) and keen to try out OpenWRT. I really can't seem to find any user success stories at all on this device. Before I take a plunge, and fall into the same 'unanswered' bricking trap, I want to ask: once I've got serial access enabled, is it possible to take my own binary dump first (before flashing OpenWRT) - and indeed is it possible to then reflash my dump to confirm that recovery is possible via serial?

If recovery is NOT possible via serial, then.. I may change my mind.

As far as I can tell, VR2600 (non -v) does not have TFTP recovery built in.

If this is your main router, I wouldn't try it. Otherwise... start by opening the case & soldering serial pins.

Compare the hardware with the images for vr2600v... it should be almost identical, except for the Broadcom part & phone stuff.

Grab the serial boot log & compare with the one on the wiki. I've got a second unit (v) that's still on latest stock (170628) and can provide the info from that one if you want to go ahead.

By the GPL sources the relevant parts are identical...

Yep, not my main router. I took the plunge and already updated the OpenWRT wiki to include this model. Installed without a hitch, all good. Of course OpenWRT reports the model as VR2600v . There might be some differences in LEDs and button configuration, so it's probably worth having a build that knows about those differences (maybe I can help with that). For now, all is good. I'm going to refine and update the docs on wiki.

1 Like

Did you work out access not via serial in any way? Or is soldering needed?

Just works via soldering... unfortunately.

Agree, I didn't see any other way, and no TFTP server seems to be running. There may well be some other way, possibly with USB, but hard to tell.

I didn't want to pull it all apart and solder it myself, and I got a quote of $50 from an electronics place, I'm not paying that for 4 pins.
I found these

Two pairs cut off the end and pushed in with pliers and you can't tell it from a bought one :slight_smile:
Just waiting on a TTL to usb cable to do the next step.

Do I need all 16 pins, or just a test clip that I can map to the correct 8 pins?

I am looking at theses

No, you dont need 16 pins but you cant use the clip either as 8 pins you need are the 2 pins on each corner

Your docs on the wiki worked perfectly with my device, thanks for the effort and time.