[NBG6817] The snapshot ImageBuilder builds appear broken (SOLVED)

I'm currently running a custom build (using ImageBuilder) of r15340 with all the packages I need built-in. Recently I'm considering building a newer image for the router, but it doesn't appear to be working.

After flashing the sysupgrade image, I'm still booting to the build I'm currently running (r15340). Even asking it not to keep the configurations (I've backed them up) doesn't help, I'm still booting to the current image with all my configurations intact.

Is the ipq806x target currently broken on snapshot? I'm currently not building for any other targets at the moment so I cannot test if others are also affected...

No. My r7800 builds work ok.

That sounds like a problem in the old firmware, not new. (The flashing never happens)


Guess I might need to flash it in some way to figure out... I'm yet to know whether the flashing really happened or not as this router has a fallback.

A self-built master/ r15583-402408b368 from ~24h ago is running successfully on my nbg6817 (and I sysupgraded a couple if times within the last 4 weeks).

I figured it out.
You have a faulty build r15340 from late December, from which you can't sysupgrade away.

The reason was that a new kernel option definition was placed into wrong location, destroying some other options. I noticed that for my own R7800 when I tried to sysupgrade to the next build.


I diagnosed that, and it was fixed by

You need TFTP flash, or some other similar recovery way (that works with your router). Sysupgrade will not work.


While push-button tftp recovery is available (and reliable on this hardware), the nbg6817 is a dual-firmware device - so you can simply switch to the other partition set (using luci-app-advanced-reboot or nbg6817-dualboot) and sysupgrade from there (the old version was obviously able to sysupgrade to the faulty one, so it shouldn't have any issues with sysupgrading to a current/ working one as well), this allows you to (if you wish) keep your configuration (at least the configuration you had in december).


Many thanks for pointing out. I switched to the firmware I had prior to r15340 and successfully flashed the one I just built. Everything's working now.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.