NAS Becomes Sporadically Unreachable Through Dumb AP

Hi there!

I have an issue with a NAS connected to my network through a dumb AP.

I am using two routers. My main router is a TP-Link Archer C7 v4, running OpenWrt 19.07.6.
My TP-Link TL-WR842N/ND v1, running OpenWrt 19.07.7, is set up as Wi-Fi bridge according to the official tutorial.
The main router is set as DNS server for the bridge and DHCP for both IPv4 and IPv6 is disabled on the bridge. I have a NAS (QNAP TS-431) connected to my bridge via ethernet to get it into the extended Wi-Fi of the main router.

network

This works mostly fine, but every few minutes the NAS becomes unreachable for a few seconds. I can see this in the output when pinging either the NAS' IP or its FQDN from 192.168.1.241:

64 bytes from QNAP.lan (192.168.1.156): icmp_seq=42393 ttl=63 time=44.6 ms
From hermes2.lan (192.168.1.3) icmp_seq=42394 Redirect Host(New nexthop: QNAP.lan (192.168.1.156))
From hermes2.lan (192.168.1.3) icmp_seq=42410 Destination Host Unreachable
From hermes2.lan (192.168.1.3) icmp_seq=42413 Destination Host Unreachable
From hermes2.lan (192.168.1.3) icmp_seq=42416 Destination Host Unreachable
From hermes2.lan (192.168.1.3) icmp_seq=42420 Destination Host Unreachable
64 bytes from QNAP.lan (192.168.1.156): icmp_seq=42424 ttl=63 time=5.57 ms

And while the NAS is up, the traceroute is what I would expect it to be:

traceroute to qnap (192.168.1.156), 30 hops max, 60 byte packets
 1  hermes2.lan (192.168.1.3)  9.345 ms  9.652 ms  10.002 ms
 2  QNAP.lan (192.168.1.156)  19.604 ms  19.671 ms  19.814 ms

(when it is down, the trace just stops at hermes2)

This occurs only for the NAS. A laptop I tried hooking up to the bridge could be pinged continously without ever becoming unreachable (192.168.1.241 → 192.168.1.100). The issue also goes away when I instead connect the NAS to the main router. I have tried all ethernet ports on the bridge and various ethernet cables.
Pinging the NAS directly from the bridge results in short stops in the ping output while the NAS is unreachable, but no "host unreachable" message there. Load on the bridge never exceeded 0.3, from what I have seen. I have not seen any related message in either System nor Kernel Log.

Anything I am overlooking here to get the NAS to connect stably?
I will happily provide additional required information for better diagnosis.

Any input would be appreciated!

P.S.: I am aware wiring the NAS directly to the main router would be preferable, but I need to get it to work via WiFi for spatial reasons.

I don't know if this will solve your problem, but try WDS instead of relayd. The setup is easy.

1 Like