NAS becomes inaccessible after upgrade to 22.03.2

Hello,

I am using a Logilink NS0045A NAS which works under openwrt 21 and older images (target: oxnas-ox820-mitrastar-stg212).
After installing current stable image 22.03.2 the NIC doesnt work anymore properly, neither ssh nor LuCI.
I was able to get into uart/serial console to assign static ip and netmask and install package tcpdump offline from SATA-hdd.
After starting ping 192.168.50.1 on my directly connected computer and ping 192.168.50.2 on NAS in background, tcpdump -n -i eth0 shows incoming and outgoing packets on the NAS. But no packets will arrive at the computer with static ip.
When I put a dumb fast ethernet switch between and start pinging on nas only activity-led of the nas shows activity. In the other case both leds show activity, but answer packets from NAS do not arrive. It seems packets transmitted from nas are invalid or broken thus being dropped by the connected device.
I‘m looking forward to your suggestions

loma1357

did you reset the settings going from 21 to 22 ?

I just did the following steps:

In failsafe mode:

root@(none):/# firstboot
[  204.017264] jffs2reset: This will erase all settings and remove any installed packages. Are you sure? [N/y]
y
[  205.571143] jffs2reset: /dev/ubi0_1 is not mounted
[  205.576320] jffs2reset: /dev/ubi0_1 will be erased on next mount
reboot

After reboot:

sysupgrade openwrt-22.03.2-oxnas-ox820-mitrastar_stg-212-squashfs-sysupgrade.tar

Reboot in failsafe mode:

root@(none):/# firstboot
[   38.221903] jffs2reset: This will erase all settings and remove any installed packages. Are you sure? [N/y]
y
[   40.479767] jffs2reset: /dev/ubi0_1 is not mounted
[   40.484925] jffs2reset: /dev/ubi0_1 will be erased on next mount
reboot

NAS is still unable to obtain ip via DHCP, with static ip no connectivity.
no luck

ok, is the NIC recognized ?

what does dmesg got to say about it ?
lspci (it's in the pciutils package, not part of the std image)

Also a few more troubleshooting commands:
uci export network; uci export firewall; ip link; ip -4 addr; ip -4 ro list table all; ip -4 ru; arp

lspci says nothing

setting static lan-ip:

uci set network.lan.proto=static
uci set network.lan.ipaddr=192.168.178.5
uci set network.lan.netmask=255.255.255.0
uci set network.lan.gateway=192.168.178.1
uci set network.lan.dns=192.168.178.1
uci commit
/etc/init.d/network restart

then:

root@OpenWrt:/tmp# /etc/init.d/network restart
[ 2614.829987] br-lan: port 1(eth0) entered disabled state
[ 2614.837306] device eth0 left promiscuous mode
[ 2614.841815] br-lan: port 1(eth0) entered disabled state
[ 2614.853642] oxnas-dwmac 40400000.ethernet eth0: Link is Down
root@OpenWrt:/tmp# [ 2616.954304] oxnas-dwmac 40400000.ethernet eth0: PHY [stmmac-0:00] driver [RTL8211E Gigabit Ethernet] (irq=POLL)
[ 2616.976509] oxnas-dwmac 40400000.ethernet eth0: No Safety Features support found
[ 2616.984138] oxnas-dwmac 40400000.ethernet eth0: IEEE 1588-2008 Advanced Timestamp supported
[ 2616.992919] oxnas-dwmac 40400000.ethernet eth0: registered PTP clock
[ 2616.999285] oxnas-dwmac 40400000.ethernet eth0: configuring for phy/rgmii link mode
[ 2617.013043] br-lan: port 1(eth0) entered blocking state
[ 2617.018304] br-lan: port 1(eth0) entered disabled state
[ 2617.024363] device eth0 entered promiscuous mode
[ 2620.153267] oxnas-dwmac 40400000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[ 2620.161551] br-lan: port 1(eth0) entered blocking state
[ 2620.166840] br-lan: port 1(eth0) entered forwarding state
[ 2620.174407] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
root@OpenWrt:/tmp# uci export network
package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd6a:975f:7875::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.178.5'
        option netmask '255.255.255.0'
        option gateway '192.168.178.1'
        option dns '192.168.178.1'

config interface 'lan6'
        option device 'br-lan'
        option proto 'dhcpv6'

uci export firewall:


package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding              
        option src 'lan'       
        option dest 'wan'      
                               
config rule                    
        option name 'Allow-DHCP-Renew'
        option src 'wan'              
        option proto 'udp'            
        option dest_port '68'         
        option target 'ACCEPT'        
        option family 'ipv4'          
                                      
config rule                           
        option name 'Allow-Ping'      
        option src 'wan'              
        option proto 'icmp'           
        option icmp_type 'echo-request'
        option family 'ipv4'           
        option target 'ACCEPT'         
                                       
config rule                            
        option name 'Allow-IGMP'       
        option src 'wan'               
        option proto 'igmp'            
        option family 'ipv4'           
        option target 'ACCEPT'         
                                   
                                       
config rule                            
        option name 'Allow-DHCPv6'     
        option src 'wan'               
        option proto 'udp'             
        option dest_port '546'         
        option family 'ipv6'           
        option target 'ACCEPT'         
                                       
config rule                            
        option name 'Allow-MLD'        
        option src 'wan'               
        option proto 'icmp'            
        option src_ip 'fe80::/10'      
        list icmp_type '130/0'         
        list icmp_type '131/0'         
        list icmp_type '132/0'         
        list icmp_type '143/0'         
        option family 'ipv6'           
        option target 'ACCEPT'         
                                       
config rule                            
        option name 'Allow-ICMPv6-Input'
        option src 'wan'                
        option proto 'icmp'             
        list icmp_type 'echo-request'   
        list icmp_type 'echo-reply'     
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'         
        list icmp_type 'time-exceeded'          
        list icmp_type 'bad-header'             
        list icmp_type 'unknown-header-type'    
        list icmp_type 'router-solicitation'    
        list icmp_type 'neighbour-solicitation' 
        list icmp_type 'router-advertisement'   
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'                 
        option family 'ipv6'                    
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-ICMPv6-Forward'      
        option src 'wan'                        
        option dest '*'                         
        option proto 'icmp'                     
        list icmp_type 'echo-request'           
        list icmp_type 'echo-reply'             
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'         
        list icmp_type 'time-exceeded'          
        list icmp_type 'bad-header'             
        list icmp_type 'unknown-header-type'    
        option limit '1000/sec'                 
        option family 'ipv6'                    
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-IPSec-ESP'           
        option src 'wan'                        
        option dest 'lan'                       
        option proto 'esp'                      
        option target 'ACCEPT'                  
                                                
config rule                                     
        option name 'Allow-ISAKMP'              
        option src 'wan'                        
        option dest 'lan'                       
        option dest_port '500'                  
        option proto 'udp'                      
        option target 'ACCEPT'                  
                                            
config rule                                     
        option name 'Support-UDP-Traceroute'    
        option src 'wan'                        
        option dest_port '33434:33689'          
        option proto 'udp'                      
        option family 'ipv4'                    
        option target 'REJECT'                  
        option enabled 'false'                  
                                                
config include                                  
        option path '/etc/firewall.user'

root@OpenWrt:/tmp# ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq master br-lan state UP qlen 1000
    link/ether f6:53:14:71:9f:ca brd ff:ff:ff:ff:ff:ff
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether f6:53:14:71:9f:ca brd ff:ff:ff:ff:ff:ff

root@OpenWrt:/tmp# ip -4 addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
7: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 192.168.178.5/24 brd 192.168.178.255 scope global br-lan
       valid_lft forever preferred_lft forever
root@OpenWrt:/tmp# ip -4 ro list table all
default via 192.168.178.1 dev br-lan 
192.168.178.0/24 dev br-lan scope link  src 192.168.178.5 
broadcast 127.0.0.0 dev lo table local scope link  src 127.0.0.1 
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1 
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1 
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1 
broadcast 192.168.178.0 dev br-lan table local scope link  src 192.168.178.5 
local 192.168.178.5 dev br-lan table local scope host  src 192.168.178.5 
broadcast 192.168.178.255 dev br-lan table local scope link  src 192.168.178.5

root@OpenWrt:/tmp# ip -4 ru

0:      from all lookup local 
32766:  from all lookup main 
32767:  from all lookup default

root@OpenWrt:/tmp# arp
IP address HW type Flags HW address Mask Device

root@OpenWrt:/tmp# ip neigh
fe80::3ea6:2fff:fe22:c52b dev br-lan lladdr 3c:a6:2f:22:c5:2b router used 0/0/0 probes 0 STALE

maybe dns server is set not correctly, but i can't access http://192.168.178.5 from my pc

with loading the initramfs-image 21.02.5 via tftp the device is working, but with 22.03.2 it won't

I would try without the bridge. I don't think it has another port or wifi, so it is not any useful.

So did this fix broken network? As it's still present on current oxnas-ox820-mitrastar-stg212 images...

hi aschuetze,

NIC driver is still broken, I also tried latest stable image 22.03.5.
Anyway, the SoC of these devices with armv6-cpu seem to be too slow for running secure and with tolerable performance in 2023.

greetings
loma1357

i used to use one with self compiled 15.05.1 back in the days which broke later due defective ram. now i got a cheap one again and would love to compile v15 once again, but all sources are broken these days. i also found samba v4 very unreliable and slow with younger openwrt versions. seems like debian may be the only solution now.