Nanostation Loco M2 - WDS link drops out after a few hours

Can't wait for warmer temperatures to get some twin cat7 to the garden house. Meanwhile switched the WDS Staion to the other WDR3600, but I have no hope that does help. Meanwhile the Ralink WDS Client bridge works, and works, and works... Somehow crazy Atheros <-> Atheros has so much problems while Atheros <-> Ralink works just perfect.

Not sure what I am missing, here are my config files:
AP end:
/etc/config/batman-adv

config mesh 'bat0'
	option aggregated_ogms '1'
	option ap_isolation '0'
	option bonding '0'
	option fragmentation '0'
	option gw_bandwidth '2000/512'
	option gw_mode 'client'
	option gw_sel_class '20'
	option log_level '2'
	option orig_interval '1000'
	option bridge_loop_avoidance '1'
	option distributed_arp_table '1'
	option multicast_mode '1'
	option network_coding '0'
	option hop_penalty '30'
	option isolation_mark   '0'

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'f::::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0 bat0'
	option proto 'static'
	option ipaddr '192.168.2.2'
	option netmask '255.255.255.0'
	option gateway '192.168.2.1'
	option dns '192.168.2.1'

config interface 'radio0_batnet'
	option mtu '1536'
	option auto '1'
	option proto 'batadv'
	option mesh 'bat0'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '6'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'HT40'
	option disabled '0'
	option country 'US'
	option legacy_rates '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'link_bridge2'
	option key 'KEY'
	option wds '1'
	option encryption 'psk2+tkip+ccmp'
	option disabled '1'

config wifi-iface 'default_radio0_mesh'
	option device 'radio0'
	option ifname 'radio0_mesh'
	option network 'radio0_batnet'
	option mode 'mesh'
	option encryption 'none'
	option mesh_id 'MACADDRESS'
	option ssid 'link_bridge.mesh'
	option mesh_fwding '0'
	option disabled '1'

config wifi-iface 'default_radio0_adhoc'
	option device 'radio0'
	option ifname 'radio0_mesh'
	option network 'radio0_batnet'
	option mode 'adhoc'
	option encryption 'none'
	option bssid 'MACADDRESS'
	option ssid 'link_bridge.mesh'
	option disabled '0'

Client end:
/etc/config/batman-adv

config mesh 'bat0'
	option aggregated_ogms '1'
	option ap_isolation '0'
	option bonding '0'
	option fragmentation '0'
	option gw_bandwidth '2000/512'
	option gw_mode 'client'
	option gw_sel_class '20'
	option log_level '2'
	option orig_interval '1000'
	option bridge_loop_avoidance '1'
	option distributed_arp_table '1'
	option multicast_mode '1'
	option network_coding '0'
	option hop_penalty '30'
	option isolation_mark   '0'

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'f::::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0 bat0'
	option proto 'static'
	option ipaddr '192.168.2.3'
	option netmask '255.255.255.0'
	option gateway '192.168.2.1'
	option dns '192.168.2.1'

config interface 'radio0_batnet'
	option mtu '1536'
	option auto '1'
	option proto 'batadv'
	option mesh 'bat0'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '6'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'HT40'
	option disabled '0'
	option country 'US'
	option legacy_rates '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'sta'
	option ssid 'link_bridge2'
	option key 'KEY'
	option wds '1'
	option encryption 'psk2+tkip+ccmp'
	option disabled '1'

config wifi-iface 'default_radio0_mesh'
	option device 'radio0'
	option ifname 'radio0_mesh'
	option network 'radio0_batnet'
	option mode 'mesh'
	option encryption 'none'
	option mesh_id 'MACADDRESS'
	option ssid 'link_bridge.mesh'
	option mesh_fwding '0'
	option disabled '1'

config wifi-iface 'default_radio0_adhoc'
	option device 'radio0'
	option ifname 'radio0_mesh'
	option network 'radio0_batnet'
	option mode 'adhoc'
	option encryption 'none'
	option bssid 'MACADDRESS'
	option ssid 'link_bridge.mesh'
	option disabled '0'

I installed openwrt-ar71xx-generic-ubnt-bullet-m-squashfs-sysupgrade.bin (OpenWrt SNAPSHOT r6177-6c2e1ff / LuCI Master (git-18.047.57952-461df8b) ), then configured the network, installed luci and kmod-batman-adv.
I then setup the network as configured above (I tried both the mesh interface adhoc configuration and the mesh interface 802.11s configuration).
With the ad-hoc, I can see the network when I scan, but it wont let me connect to it.
With the 802.11s I can see a network, but the SSID is the mac address from option mesh_id, not the one from option ssid for some reason.

Aaron Z

install batctl utility

please check :

dmesg: 	batman-adv interface created 
	wifi adhoc initiated / connected

ifconfig -a	 verify bat0 interface exists and active/connected

batctl -o	list all mesh originator/stations with resp. link quality
	
brctl show  batman-adv interface ( bat0 ) added to br-lan

test mesh connections  (layer 3 / IP )
	verify every node its LAN interface configured with IP / mask for same LAN-segment
	connect client ( static IP LAN-segment of nodes ) to br-lan  ( ehtx / WIFI-AP)

DONT connect client to adhoc/mesh WIFI, use LAN / AP instead

greetings

In mode mesh (802.11s), option ssid is not used. Nodes must have matching mesh_id. The mesh_id is broadcast in beacon frames much like a SSID would be. You can use a mesh_id that looks like a MAC address but not the station's unique MAC. It has to be the same on all the nodes.

The MAC-like ID such as 'CA:FE:BA:BE:00:00' is a holdover from adhoc, which required a MAC-like address to determine which stations are participating in the network. 802.11s mesh_id can be any text.

802.11s with mesh_fwding set to 0, to delegate forwarding to an external process like BATMAN, is the currently preferred method. It has better driver support than adhoc.

@aczlan

Do you have some cheap china IP cameras on your network? Just noticed my other WDR3600 is also getting unstable since I added a new IP camera to the WiFi of this one. AND I already have two of these outdoors for which I use the WDS bridge. Maybe there is some correlation.

This is totally crazy, the latest snapshots made it worse again, max uptime of the WDS bridge now -> just a few hours max. Could get a few days just 2 weeks ago.

Ordered myself a Linksys WRT1200AC v2, WDS bridge up and running (so far, so good...). Let's see if the Marvell <-> Atheros bridge is more stable.

2 days now, a few hiccups (CPE210 sometimes gets high ping and disconnects for a few seconds) but WDS still up and running. Ralink rock solid as before ( is there any outdoor AP with ralink chip? :wink: )

Edit: Some major changes (4.14 kernel and new wifi driver/firmware) for mvebu got pushed to snapshots 25mins ago. I'm curious abut tomorrows WRT1200 build :wink:

Now it's official: It's def. something on CPE210 the client side. CPE210 still connected but no ping. Good thing: All other 2,4 GHz Clients on WRT1200 still connected and stable. Next Question: Is it something that is connected to the CPE210 (China WiFi Cameras) or the CPE210 itself that causes it to break.

EDIT: LOL, after about 2 hours, the CPE210 reconnected and the WDS bridge simply came back to life without me doing anything...

Good luck, I gave up on mine. Not enough time to troubleshoot it and my long-suffering wife had enough of restarting the client end so I put the stock firmware back on and I haven't had to touch it since. I might try again with some other devices to setup another point to point link, but not with the Nanostations.

Aaron Z

Problems still present on WRT1200AC Station with CPE210 Client. I also give up on this... Atheros WDS Clients and OpenWRT are not supposed to be friends, no matter what Chipset the Station uses ... I guess.

@cyablo Sorry, I missed your question about cheap cameras. No wifi cameras on the network cheap or otherwise.
Just 5-6 PCs (all on Windows Vista or 7, usually not more than 2-3 in use at a time), 2-3 printers, 1-4 tablets, 2 Roku3s, a couple of blue ray players, 2 Nanostations and 2-3 APs.

Aaron Z

Greetings Aczlan, I have a nanostation locom2 xw, I want to install lede but on the page do not support this model, you say you have two with this version, I would like to know which firmware can be installed, and the procedure to do it, I would really appreciate it help

Mine are the older Nanostation Loco M2 XM, not the newer XW variant that you have.
The XW install file is listed at being available at: http://downloads.lede-project.org/releases/17.01.4/targets/ar71xx/generic/lede-17.01.4-ar71xx-generic-ubnt-loco-m-xw-squashfs-factory.bin
Note that some have had issues with them requiring a signed file to upgrade from the web interface (so that you cannot flash 3rd party firmware to it).
This has a low amount of memory/RAM (4MB/32MB), so it is limited on what packages can be installed as well and may not be supported in the future.

Aaron Z

There is a loco XW build. An XW should have 8/64 memory. However some early XW had a buggy Ethernet chip.

My nano loco m2 xw has 8 MB of flash and 32MB of ram, the version that is in that link is for the nano loco m5 xw, according to the table of hardware of the blog, I ask: it serves me for the loco m2 xw, why Support was given to locom5 xw and locom2 xw no, I acquired it in February of this year, on Amazon, greetings, help me if you can