NanoPI R6S with OpenWRT

yes it's M2 nvme;

I tried that approach with modprobe but failed to see any NVMe attached. It works on FriendlyWRT out of the box, and similarly on Debian Bookworm with kernel 6.1.

I am considering using Debian as my main OS now and running OpenWRT in a Docker container. It looks like the snapshots are stable but missing some crucial functionality.

root@OpenWrt:~# uname -a
Linux OpenWrt 6.6.32 #0 SMP Sun May 26 02:19:39 2024 aarch64 GNU/Linux
root@OpenWrt:~# lspci
0003:30:00.0 PCI bridge: Rockchip Electronics Co., Ltd RK3588 (rev 01)
0003:31:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 05)
0004:40:00.0 PCI bridge: Rockchip Electronics Co., Ltd RK3588 (rev 01)
root@OpenWrt:~#

It could be a NVMe SSD controller issue, the one I have installed on the r6c has never failed.

root@R6C:/# lspci
0003:30:00.0 PCI bridge: Rockchip Electronics Co., Ltd RK3588 (rev 01)
0003:31:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 05)
0004:40:00.0 PCI bridge: Rockchip Electronics Co., Ltd RK3588 (rev 01)
0004:41:00.0 Non-Volatile memory controller: Phison Electronics Corporation E12 NVMe Controller (rev 01)

@antoncycle I am pretty sure we can narrow this down to openwrt snapshots bc on friendlywrt or debian, it works perfectly fine:

lspci -v

0004:41:00.0 Non-Volatile memory controller: MAXIO Technology (Hangzhou) Ltd. NVMe SSD Controller MAP1202 (rev 01) (prog-if 02 [NVM Express])
	Subsystem: MAXIO Technology (Hangzhou) Ltd. NVMe SSD Controller MAP1202
	Device tree node: /sys/firmware/devicetree/base/pcie@fe190000/pcie@0,0/pcie@40,0
	Flags: fast devsel, IRQ 113
	Memory at f4200000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable- Count=1/32 Maskable+ 64bit+
	Capabilities: [70] Express Endpoint, MSI 1f
	Capabilities: [b0] MSI-X: Enable- Count=9 Masked-
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [148] Device Serial Number 00-00-00-00-00-00-00-00
	Capabilities: [158] Alternative Routing-ID Interpretation (ARI)
	Capabilities: [168] Secondary PCI Express
	Capabilities: [1d4] Latency Tolerance Reporting
	Capabilities: [1dc] L1 PM Substates

Not really, the FriendlyWrt, as well as the Debian you are using aren't using upstream kernel, it's a customized kernel from FriendlyElec, currently there is no working solution in kernel 6.6 or before:

With such a speed of development, it is likely that mainline kernel for NanoPI R6S will appear next year :frowning_face:?

Yeah sure, that's what I meant: FirendlyWRT has patched the 6.1 kernel.

I thought mj22226 [mj22226] is doing exactly the same, and he patched the kernel.

Patching can be done by anyone, the most important thing is "upstream to mainline Linux kernel", one can always find a dirty quick fix to patch the code and make it working, but how about kernel version upgrade? With a mainline kernel you have kernel.org to do all updates which is scalable.

The latest changes in the linux kernel for r6s have been made 2024-02-29 :roll_eyes:.

1 Like

Did anyone install RTC battery for R6S ???

Yes

[    0.413345] rtc-hym8563 6-0051: registered as rtc0
[    0.414809] rtc-hym8563 6-0051: setting system clock to 2024-06-30T08:59:54 UTC (1719737994)
1 Like

Thanks for info.

What battery did you used and how much space is to fit it there?

CR2032

But the case do not have enough space

Did you tried CR1025?

Are you using it without case???

What about temperatures?

BTW... what power supply are you using? V and A values?

I tried using 6.6 but couldn’t get any network connectivity. WAN couldn’t pull an ip. Also idk why but openwrt snapshots for r6s seem to get the ports confused. Starting from the port right next to the power port it’s eth0 then 1 then 2 but on 6.1 it thinks eth2 is eth1. Same wirh 6.6 snapshot. I loaded up 6.1 and it worked with internet right off the bat. Then again I’m not too experienced with open source firmware as it’s only been about almost a year since I purchased the nano my first x86 open source router. But if you or anyone else has any tips on how to make internet work on 6.6 it would be appreciated but 6.1 works rock solid.

Do you know how to get temperature readings for the nano r6s?

No I only have CR2032

Yes without case but I have fan with it

soc_thermal-virtual-0
Adapter: Virtual device
temp1: +46.2°C

lm_sensors
https://wiki.archlinux.org/title/Lm_sensors

Also I know this is off topic but since I am using the R6s with no WiFi. I have an ASUS router that has access point mode enabled. Is there anything else I need to do on r6s to configure for my AP or just plug it in and leave it.

46C is not bad.

I'm still waiting for my R6S to be delivered to me.

When it will arrive I will check how much space is there... then maybe will try with smallest 3V RTC battery. If not... will just give up to have this RTC battery and will use time from internet servers.

I currently use Intel NUC mini PC as OpenWrt router + 2 x Linksys WiFi 6 AP.

Linksys AP are in bridge mode and works as simple WiFi AP.

The only thing what I would suggest is to give AP static IP address. Then you will always know what IP use to log in to it.

But if you don't want to use static IP for AP... just connect it to your local lan and configure WiFi.