NanoPi R4S-RK3399 AND R6S-RK3588S is a great new OpenWrt device

I was reading the instructions on

which is linked from the nanopi installation page

I understand that it says "To use the whole available space of your sdcard, you probably have to resize your partition. " but it doesn't say that I don't have to or that by doing so that I make some things more difficult.
It will be far easier to hang a usb stick on a port as a place for storage imo and - - - it looks like anyway - - - and lot less headache.

Thanks for the information.

Use the ext4 image and add another partition. Mount it into your filesystem and job done.

Bonus is that as long you keep the partitions as they are you can save your docker images etc to the additional one and an upgrade will only overwrite the first two partitions.

root@OpenWrt:~# fdisk -l
Disk /dev/mmcblk1: 29.72 GiB, 31914983424 bytes, 62333952 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: CF928C8C-1A6B-4405-B244-23DD8E7195A8

Device           Start      End  Sectors  Size Type
/dev/mmcblk1p1   65536   147455    81920   40M Linux filesystem
/dev/mmcblk1p2  196608  2293759  2097152    1G Linux filesystem
/dev/mmcblk1p4 2293760 62333918 60040159 28.6G Linux filesystem
root@OpenWrt:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root              1007.9M    329.7M    662.2M  33% /
tmpfs                     1.9G      2.6M      1.9G   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mmcblk1p4           28.6G      2.7G     25.9G  10% /opt
cgroup                    1.9G         0      1.9G   0% /sys/fs/cgroup
/dev/mmcblk1p4           28.6G      2.7G     25.9G  10% /opt/docker
overlay                  28.6G      2.7G     25.9G  10% /opt/docker/overlay2/28e413109131a245638b02cd3126a72fa29737e24de8069acdbd926df9bf632d/merged

docker work on 22.03?

I've not upgraded. I'm using older anaelorlinski build but he has a new one out now.

I'd rather keep the AES encryption boost (they are still arguing over it cos the stupid Pi doesn't support it and thus screws things up for everyone.)

Firmware Version:AO Build@2022.03.29

Looks like crypto extensions are being fixed.

Is there any difference between "no hardware MAC" version and normal (hardware MAC?) version for OpenWRT?

Working on (still) setting up my first iteration of OpenWRT on a nanopi R4S 4GB.

I am thinking of adding a USB stick for greater memory.

Is it possible to run a routing system working at either of 250 or 500 Mbit down/up (symmetrical)
and having enough horsepower left to also add a voip system running on asterisk?
Any caveats/gotchas or other setup tips?


3.2 Differences Between R4S Standard Version & R4S Enterprise Version

The R4S Enterprise version has a built-in EEPROM chip (Model: 24AA025E48T) which has a globally unique MAC address. This is a permanent and temper-proof address.
The R4S Standard version doesn't have this chip and has a MAC address that is generated by a software utility. Apart from this difference, the two versions have the same hardware configuration.

The Standard version doesn't have a MAC-address built-in EEPROM chip while the Enterprise version does. Both the Standard version and the Enterprise version have the same network chips (RealTek RTL8211E and R8111H). For more details please refer to the following screenshot. Retail users are recommended to choose a Standard version and enterprise users are recommended to choose an Enterprise version.

Tips: most of the existing embedded ARM boards such as RPi 3B have MAC addresses that are generated via software utilities. This generally doesn't have impact on network communication. Globally unique MAC addresses lead to better network performance in complicated network situations and are better for large-scale enterprise applications that manage multiple network devices and operations such as IP binding.

In short just make sure the Mac is unique and doesn't clash in your network and you will be fine.

1 Like

Official ram patch from friendlywrt. Will test it later on my R4S 1GB


Managed to complete this this morning.

Able to log in using ssh but Luci doesn't seem to want to work.
Is Firefox possibly a problem? (Its http and not https)

So thank you for your well written guide - - - muchly appreciated!!!


Am working on completing all the setup and am running into a problem.

I used the squashfs


for my install.
I am getting software errors like

* pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.144-1-23c3f734f8e38fe957092b233241bf3b) for kmod-usb-core

#uname -r Linux memyself 5.10.139 #0 SMP PREEMPT Sat Sep 10 02:23:20 2022 aarch64 GNU/Linux

A update cycle does not clear this.

How do I update the kernel so that I can use a USB stick for storage?


Are you using snapshot instead of 22.03 stable? Every time snapshot gets a kernel update, which happens often, many/most packages become incompatible with any prior snapshot image. You should install all packages you would like to have immediately after installing a snapshot image to avoid this. Even better-use the image builder and add your desired packages to your image (including luci) before you install it.

This may also be why you do not have luci. Pre-built stable release images come with luci. Snapshot images and images built with image builder (whether stable or snapshot) do not - you must add the luci package (along with any others you want) yourself in this case.

Edit: If your issues are not specific to the NanoPi R4S, consider posting issues with installing and using OpenWrt in the "Installing and Using" sub-forum.

Hmmmmmmmmmmm - - - not sure if my issues are specific to the nanopi install or not - - - please advise (I don't want to cross post!!!).

I have absolutely NO idea what all packages I need never mind what I want or I would have installed them at the time.

How do I 'fix this'?

This was my install - - - I see nothing that labels it as a snapshot but when I do a
opkg update the responses start . . .
so I have a 'snapshots' version.

Can I 'upgrade' or what do I do?


I have tried it and it works :grinning:

Did someone manage to install OpenWRT on the eMMC memory of the R4SE? Just tried to flash the OpenWRT Image with eMMC tools as described here.
No error during the installation, but after reboot, only the power led is lit and the nanopi does not boot.

FYI: I updated to yesterday's MASTER (SNAPSHOT, r20860-c27b439564) about 4 hours ago after the last missing piece for kernel 5.15 support got pulled ( Git - openwrt/openwrt.git/commit). So far everything looks good + stable.

1 Like

I designed a simple 3d printed fan shroud that fits on top of the R4S OEM aluminum case. Here is the Thingiverse file, if anyone wants to add a fan to their case.


Nice thanks, but is it necessary? On mine the temps are always between 40 and 45 degrees. Quite low!

I don't think it is necessary in most cases. I have Jellyfin running in a docker container on mine and temps were getting past 60C when Jellyfin has to transcode video to a lower resolution when I VPN from my phone. With the fan, I doesn't seem to go past 45C when transcoding.

It does make it run cooler though and it is cheap to add a fan.

60°C is not even high for such device.

As long as you're below 80-90 °C there is absolutely no reason to cool it, except if you look for noise and power consumption bump.

And 80°C will never happen with this device, even under stress testing.

So from my point of view, there is no reason to cool it actively (I mean the version with metal case)

1 Like