NanoPi R4S-RK3399 AND R6S-RK3588S is a great new OpenWrt device

The ingress speed wasn't capped at 920, but the speed was unstable. It would run at 940Mb for about 5 seconds and then drop to 750Mb for a bit, then back to 940. So the dips to 750Mb were bringing down the average even though it was mostly at 940. I'm not sure what was causing the dips to 750, maybe a driver issue. I didn't have any ping spikes unless I tried pushing symmetrical gigabit with SQM set to 1000/1000, or writing to a USB drive while running a bufferbloat test.

After the tests I came to the conclusion that you can get stable symmetrical SQM by dropping it to 850/850, or asymmetrical at 1000/700. Would recommend putting the queues on the A72 cores and IRQs on the A53 cores to achieve this.

1 Like

Can you post a link to the settings in use during those tests? I have a unit out for delivery this week and can give those recommendations a try.

For the tests I was using Cake / piece_of_cake with bandwidth set to 1000000 kbit/s both directions. Everything else was default, so no link layer adaptation.

I also got rid of the bridge on the LAN interface so that LAN was running directly on eth1. I think it reduces overhead a little bit not having an unnecessary software bridge in there.

And again, best results were achieved with queues on the A72 cores and IRQs on the A53 cores. Instructions for this are in the wiki.

Other than that, I didn't tweak anything else.

are you using irqbalance and packet steering?

No I set them manually. See wiki for instructions.

I have posted instructions here. You might need to install extra packages if using OpenWrt builds.


Ok I will take a look (and a try)
Does it remain after a new openwrt update?

I don't seem to be able to find an image that boots.

I was running a random snapshot and it mostly worked, except for the reboot issue. I saw that was fixed and wrote the latest snapshot to my SD card, but it doesn't boot. I tried 22.03.0-rc1 and that doesn't boot either. Physically, the red light turns on. However, none of the green lights ever turn on.

Does anyone know what might be going on?

Hi, I have got my new R4S 1GB today. I flashed last Snapshot Image and it doesnt boot up. Tried anaelorlinski build with uboot patch and it booted up.

I am an idiot; I just realized that I forgot to unzip the image(s), before writing to my SD card! Please disregard my last post.

Its just like what i said in the quote that you did of my post.

There is no official support for the 1gb version in official openwrt! It works in anaelorlinski cause he added the patches from uboot needed for the 1gb version to work himself.

I'll be honest, i don't think anyone is going to add support for the 1gb version unless you do it yourself cause like said: 90% or more got the 4GB version.

But if the only changes needed are those 3 uboot patches, then you can easily build openwrt yourself and add those uboot patches and see if it works.


Someone will have to submit (and follow up with eventual change requests) the necessary patches for adding support for the 1 GB RAM device variant. There's no reason not to merge it, but someone will have to do the necessary work - and that can only be done by those who own the affected device.


If I remember correctly the original patch for the 1 GB version did not get merged, because the developers suggested to directly submit it to u-boot instead of integrating the u-boot patch to openwrt.


That's entirely possible (I'm not following rockchip development that closely, as I don't own any devices with it), but that doesn't really change the underlying situation, just the address where you'd submit the changes (and as soon as they are applied at u-boot upstream, there's no reason why OpenWrt wouldn't accept a backport of those changes; I certainly understand why OpenWrt wouldn't want to sit on u-boot patches forever, if the rest of the target is supported in mainline u-boot just fine).


I'm now running the latest snapshot and still having the reboot issue. I read earlier in this thread that issue was solved. What am I missing?

What is very weird is that I have two R4S and only one has this issue. They are both using a 32gb Sandisk High Endurance SD card. They run different configurations, but are both running snapshot.

Oh this is a nice find ill be honest! Cause today in a another forum some ppl reported the same and this issue does not happen to me at all!

But i am using a custom snapshot build with kernel 5.15 + r8168 driver instead of r8169 + firmware 8169 and i also used patches 300 to 308 from here:

And driver r8168 from here:

Does the led light for the lan port stays off when you reboot, while the wan and sys are on? Did you try friendlywrt? The people who reported on another forum said that it happens with friendlywrt as well! But one person tried OPNsense and the problem does not happen there! So a software fix might be possible with openwrt!

You should try friendlywrt and if it happens there, i would then contact friendelec, give them the logs and ask them to fix it.

Hi, I just bought a R4S that I want to use for replace my Netgear R7800, but I have some doubts, if I’m not annoying I would ask:

I’ve seen that I have to install it from the SD, but there’s also a 32gb of storage inside?! So it’s possible to install OpenWRT there?

Since I’m a bit/lot lazy, my idea is to export a backup of my actual router and import it into the R4S, but I have never done a similar thing before. Is it possible? I will have lots of troubles? Also because the R7800 has the wireless antennas… maybe is possible to export only some configurations (like the interfaces not wireless, WireGuard, firewall, etc..) only?


Looks like you bought the R4SE, not the R4S 4GB. Only the R4S 4GB version is supported by OpenWrt.

That will not end well. The R7800 network configuration file setup is swconfig based. The R4S is DSA based. The setup is not the same.

1 Like

I’ve bought the R4S. I was reading online that it has also the storage inside, I didn’t know the one with the storage is another model ( the R4SE), so thanks for the clarification!

About the configuration, what’s a DSA based? What means DSA? (Data Storage Area)?

But is possible to export (or import) only some configurations with OpenWRT? Not a complete backup I mean but a way to automatically select what to backup/import. If yes, I will have troubles also in this way?

Distributed Switch Architecture refers to the switch control software. OpenWrt is slowly converting targets from swconfig to DSA.

Even if the R4S were still swconfig, I would still not import a backup from a different device. Any device specific configuration difference, not just DSA, is going to create an annoying bug you'll waste more time finding and fixing then just starting fresh. With DSA its the network file you need to worry about, so sure, use your backup as a guide (firewall rules, dhcp setup, etc.), but I would configure your new device manually.

1 Like