Nanopi R4S (4GB) install problems

Greetings back, but not sure what you want to say with your post. People buy the R4SE to be able to run it without an SD Card and want openwrt running/booting from the emmc. So not sure about the value of your comment.

Me too, I only know how to compile snaptshots of OpenWRT

Yeah, but the price is a little high for me, I was looking a R5S but isnt supported in OpenWRT, and the prices of R4S, R4SE and R5S are near each other

Well I was thinking, run from eMMC, if someday breaks, run from sdcard, but isnt supported, and I was looking to replace two raspberrypi 4 to get rid of the fan, but anyway Im getting offtopic here.



Just came across this post and on Aliexpress price looks similar to R4SE. Also early days on that thread but something to keep an eye.

Not sure I understood the initial post question here, but if it is how to expand the uSD card filesystem so it can take advantage of the whole uSD card size instead of the default 100mb filesystem that comes with the OpenWRT image, I can report did the following successfully:

Had a fully working uSD card with OpenWRT, as described in previous posts on this thread.
Then, in a linux box:

Put the card in a card reader
sudo dd bs=4M if=/dev/sdc | gzip > ./nanopi_date +%d%m%y.gz
(created a uSD card backup to a file in the linux box.)

take the card, put another one and:
sudo gzip -dc ./nanopi_161222.gz| sudo dd bs=4M of=/dev/sdc
(restored the backup to other uSD card)

Tested the card in nanopi. It works, so the backup/restore worked fine.
Then, put one card in the linux box again and expand the partition with
sudo cfdisk /dev/sdc
(this is an interactive command, but quite intuitive)

Then, the partition is expanded, but the filesystem still needs to be expanded as well, so:

sudo e2fsck -f /dev/sdc2   
sudo resize2fs /dev/sdc2    
sudo e2fsck -f /dev/sdc2

Tried the card in nanopi, and viola! I have a filesystem of ~31.5GB available!

Your uSD device in your linux box may be different than /dev/sdcx. If you don't understand why is that you may want to ask help in a *nix forum, because a little mistake with dd can destroy anything.
(people used to call 'dd' "disk destroyer" for some reason :slight_smile: )
The dd command sometimes can take up to 1 or 2 hours without any feedback. Just be patient.

Sorry for having my previous posts slightly off-topic, but I hope to compensate with this.

Hope it helps. Happy OpenWRTing!