Nanopi R4S (4GB) install problems

Dunno - - - I seem to more lost - - - don't even know how to get out of the hole I'm in.

Asked my question over on the 'dev' side of things.
Likely they will rant over such noob questions.
Dunno how to do this - - - the destructions I can find are incomplete and assume a lot of knowledge and activities I know nothing about.

Getting hard to keep asking questions.

Can't even find any routers for sale in the area that are supported on Openwrt.
Really don't like the option the new ISP is offering ( a M$ win controlled Mikrotik) but I'm running out of ideas and would like a functioning router.

To be very honest, you may be better served paying someone local to help you out and put it all together for you. It's pretty common even with 'prosumer' gear like Ubiquiti.

Hmmmmmmm - - - and how do I find such unobtanium?

Well, I suppose you can inquire here, or Craigslist is probably a decent option. There's enough OpenWRT knowledge around the world that there has to be someone local in your area, but it's pretty clear that forum support isn't going to be sufficient. Unfortunately, OpenWRT still hasn't quite reached the level of plug-and-play, particularly on specialty hardware.

You make some interesting assumptions - - I'd be willing to bet a good steak dinner that there likely isn't such a knowledgeable person within 20 minutes drive (in any direction!).

Curious as to what makes it '. . . pretty clear that forum support isn't going to be sufficient.' ?


Any update on this thread?
I've just received my nanopi R4SE and I don' trust the friendlyWRT FW that comes with it. I just want to install the latest OpenWrt release there.

I'm following the instructions above (downloading the correct FW and copying it to the SD card with Win32imager) and I boot the Nanopi with the SD card inserted (I'm simply inserting the SD card and force a reboot - Not sure if anything else is needed, at least nothing is stated anywhere).

However, it seems the SD card is ignored by nanopi and the friendlyWRT loads instead. I've tried different SD cards already and the result is the same.

SSH'ing into the friendlyWRT I'm able to mount the SD card and see the OpenWRT contents, so the card seems to be OK. Just not sure how to force Nanopi to boot from it.

Any suggestion?

To boot from the SDCard you either have to press the Mask Button or you would need to overwrite the Loader on the emmc.

1 Like

That was it! Thanks a million!

I had missed that chapter, but had tried booting with the mask button pressed. It seems I didn't hold it for enough time.

You saved my day :slight_smile:

Did you just used the mask button option or did you also tried the boot loader overwriting?
My emmc is giving me issues so I haven't been able to try the boot loader overwrite.

I used the mask button.
Then, already in OpenWRT I did something stupid but by then seemed fine:

dd if=/dev/mmcblk2 of=/dev/mmcblk1

Basically I wanted to copy the contents of sd card to emmc.

Now it can only boot with the mask button on :frowning:

Welcome to the club.
While I installed my image via the Friendlywrt Webinterface but same result the emmc is not visibile anymore. Booting openwrt SD Card via mask button works but none of the friendlywrt recovery SD's working anymore. Will have to connect a UART when I have time.

BTW you wrote of=/dev/mmcblk1, based on the friendlywrt page they overwrite the Loader on mmcblk2.

Have you tried it?
I've just been able to load a friendlyWRT image back to the nanopi, what an adventure!

Then it booted automatically to friendlyWRT without mask button. Not exactly what I wanted, but at least it booted something in case of a power outage.

This friendlyWRT version had the eMMC tools option in the GUI, while the other coming from factory didn't.

Tried to upload an openWRT image throught the eMMC tools option, it bricked the device again (had to recover it again with UART procedure).

But then when using the dd if=/dev/zero of=/dev/mmcblk2 bs=8M count=1 option, I'm now able to boot from the SD. :slight_smile:

I guess it will not be possible to load OpenWRT on the eMMC, unless it uses the Rockchip MiniLoader.

As this is currently my main firewall I haven't had time to dismantle it.

Ok, based on the screenshot you used the Windows Recovery tool? Maybe I try that.

Well at least that makes the device useable.

Agree that a openwrt on the emmc might be a long shot but maybe one day someone make it happen.

Thanks for the info, I was about to buy a Nanopi R4SE, but if is unable to boot OpenWRT from the eMMC, I will choose another model .


Well, not sure if it is possible/easy to have OpenWRT booting with Rockchip miniLoader. It's beyond my knowledge and understanding.

To be honest, if it was today, I'd buy this one instead: It is a "pure RPI4" with 2x GB ports, so compatibility should be much easier.

But to be fair, I think I feel safer to boot from the SD card. I plan to have another card as a backup, so if I get any corruption, I can easily replace it. Having a corruption in eMMC would be more troublesome to recover.

Gabriel Ramirez gabrielo
December 15 |

  • | - |


I guess it will not be possible to load OpenWRT on the eMMC, unless it uses the Rockchip MiniLoader.

Thanks for the info, I was about to buy a Nanopi R4SE, but if is unable to boot OpenWRT from the eMMC, I will choose another model .


If you load the FriendlyWRT - - - you're going to get the FriendlyWRT.

If on the other hand you follow the directions for burning OpenWRT on your SD card
well - - - you'll have something different.

What to load - - - sorry that's what I'm working on.
I do have a functioning openwrt on my Nanopi R4S.


Greetings back, but not sure what you want to say with your post. People buy the R4SE to be able to run it without an SD Card and want openwrt running/booting from the emmc. So not sure about the value of your comment.

Me too, I only know how to compile snaptshots of OpenWRT

Yeah, but the price is a little high for me, I was looking a R5S but isnt supported in OpenWRT, and the prices of R4S, R4SE and R5S are near each other

Well I was thinking, run from eMMC, if someday breaks, run from sdcard, but isnt supported, and I was looking to replace two raspberrypi 4 to get rid of the fan, but anyway Im getting offtopic here.



Just came across this post and on Aliexpress price looks similar to R4SE. Also early days on that thread but something to keep an eye.

Not sure I understood the initial post question here, but if it is how to expand the uSD card filesystem so it can take advantage of the whole uSD card size instead of the default 100mb filesystem that comes with the OpenWRT image, I can report did the following successfully:

Had a fully working uSD card with OpenWRT, as described in previous posts on this thread.
Then, in a linux box:

Put the card in a card reader
sudo dd bs=4M if=/dev/sdc | gzip > ./nanopi_date +%d%m%y.gz
(created a uSD card backup to a file in the linux box.)

take the card, put another one and:
sudo gzip -dc ./nanopi_161222.gz| sudo dd bs=4M of=/dev/sdc
(restored the backup to other uSD card)

Tested the card in nanopi. It works, so the backup/restore worked fine.
Then, put one card in the linux box again and expand the partition with
sudo cfdisk /dev/sdc
(this is an interactive command, but quite intuitive)

Then, the partition is expanded, but the filesystem still needs to be expanded as well, so:

sudo e2fsck -f /dev/sdc2   
sudo resize2fs /dev/sdc2    
sudo e2fsck -f /dev/sdc2

Tried the card in nanopi, and viola! I have a filesystem of ~31.5GB available!

Your uSD device in your linux box may be different than /dev/sdcx. If you don't understand why is that you may want to ask help in a *nix forum, because a little mistake with dd can destroy anything.
(people used to call 'dd' "disk destroyer" for some reason :slight_smile: )
The dd command sometimes can take up to 1 or 2 hours without any feedback. Just be patient.

Sorry for having my previous posts slightly off-topic, but I hope to compensate with this.

Hope it helps. Happy OpenWRTing!