NanoPI-R2S VLAN network fail to work

Ethernet PHY broken PPPOE VLAN dialing is not working!

What fails? I dont have any problems in 2 days with that commits

Well i don't use PPPoE, just the VLAN tagging. Let's see if any one has the same problem.

I have simple static setup for testing and also noticed that clean setup of latest snapshots breaks WAN interface.

root@OpenWrt:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether 16:61:ae:6a:80:0c brd ff:ff:ff:ff:ff:ff
    inet 10.65.1.20/24 brd 10.65.1.255 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fe80::1461:aeff:fe6a:800c/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel master br-lan state UP qlen 1000
    link/ether 16:61:ae:6a:80:0d brd ff:ff:ff:ff:ff:ff
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether 16:61:ae:6a:80:0d brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd45:b019:db8e::1/60 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::1461:aeff:fe6a:800d/64 scope link 
       valid_lft forever preferred_lft forever
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd45:b019:db8e::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_eth1_dev'
	option name 'eth1'
	option macaddr '16:61:ae:6a:80:0d'

config interface 'wan'
	option ifname 'eth0'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '10.65.1.20'
	option gateway '10.65.1.1'
	option dns '10.65.1.1 1.1.1.1'

config device 'wan_eth0_dev'
	option name 'eth0'
	option macaddr '16:61:ae:6a:80:0c'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

Interface is UP but gateway is not pingable

I can confirm precisely the same behaviour.
The LAN interface eth1 is working without any problem whereas I don't get any response on the WAN interface eth0.
For further analysis I connected the WAN (eth0) interface to my existing local network and connected just my laptop to the LAN (eth1) interface.
With tcpdump running on both sides I can see incoming multicast packages on the WAN (eth0) interface but I don't see any outgoing packets on the network. For a ping I would have expected to see at least the ARP packets.

In short RX seem to work but TX not.

I have also a clean initial setup like the post before with a static IP configured.

Finally it was commit bda6f6572be630bcf9a1c8a429e40d8a53033af5

The change of

clock-output-names = "gmac_clkin"; to
clock-output-names = "gmac_clk";

drivers/clk/rockchip/clk-rk3328.c is providing gmac_clkin
After reverting it to gmac_clkin the WAN interface (eth0) started working again

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.