NanoPI R2S is a great OpenWrt device

Ethernet via USB 2.0 is usually not suggested.

My suggestion would be to spend around $29 and get a TP-Link SG108E switch.

With VLAN tagging, it would allow you to use every port of the switch as if it was connected to the NanoPi itself. (this is my current setup)

mwan3 should work with the default configuration, just don't forget to assign metric to each interfaces.

Have you considered trying out MPTCP instead of mwan3?

Good call on the VLAN tagging, @jayanta525. I haven't thought about that.

Currently I have a Ubiquiti ER-X running Openwrt 19.07. It works well, but the CPU can only handle around 200Mbps on SQM and my internet are 300Mbps + 120Mbps downstream, so I'm leaving a lot on the table.

I think I'll just configure the VLAN tagging on the Er-X to match the NanoPi then and let Nanopi do the routing and SQM.

Hi,

Simple question: what is the tool you are using to do your SQM tests ?

Thanks

This is an interesting change to build an NTP time server that I'm interested in. :grinning:

There are a few sites that describe how to do this with Raspberry Pi; I have run Pi3 and Pi4 as my OpenWRT router over the past ~2 years, I have been using Nano Pi R2S with FriendlyWRT for the past 2 months. You can buy a GPS receiver with PPS output for about $13 USD (you may need an antenna and adapter cable - another ~$13).

There are a couple tests I use:

  • speedtest-netperf is a package you can install via opkg and was written by some of the same gurus that brought SQM around to begin with. A word of caution, though... depending on your WAN speed, it's likely the speedtest-netperf.sh script should NOT be run directly on your NanoPi. At higher WAN speeds, the routing cycles on your NanoPi can be disrupted by the load that netperf & netserver add during the speed test and your results will not be accurate in that case.
  • Flent is another awesome tool with a little bit of a learning curve. But definitely worth learning. I am not an expert in it by any means, but there are others (@moeller0 and @dtaht, just to name a few) that frequent this forum who can interpret the heck out of Flent charts and teach us all a thing or two.
  • Netdata-chart-sqm is another "tool" (not so much a test) I posted about here. There is absolutely nothing wrong with hard-numbers in a CLI--in fact I prefer that in most cases. But there are also some times where being able to get a more real-time visual of what is going on in your SQM queues & tins is beneficial. This chart is for getting that sort of visual via Netdata. I personally have found that Netdata itself is lighter on resources than even Collectd, but YMMV.

Hope my responses didn't overwhelm for a "simple question"... :slight_smile:

No perfect.

I would be interested to get netdata-chart-sqm.

I'm newbie to Openwrt. I tried to install git to clone netdata-chart-sqm but the package is not available. Do i need to update the disfeeds.conf or customfeeds.conf ?

Thanks

No worries! Short answer is that it's not yet a package. I would be willing to take it that direction at some point if people find it useful, but I haven't gotten much feedback to-date.

To install it, follow the directions here: https://github.com/Fail-Safe/netdata-chart-sqm#installation

I don't want to take this thread too far off-topic, so feel free to fire any more netdata-chart-sqm follow-up questions my way over on this thread: SQM Reporting?

1 Like

Hi,

Could you please share your distfeeds.conf and customfeeds.conf ?

Mine is reporting this :

src/gz openwrt_core http://downloads.openwrt.org/snapshots/targets/rockchip/armv8/packages
src/gz openwrt_base http://downloads.openwrt.org/snapshots/packages/aarch64_generic/base

I'm missing the pakcages openwrt_packages.... can i just add it ?

Hi @jayanta525, added this setting to /etc/config/network (please find the complete network under my comment.

I'm getting no internet connection on my WAN (i need for T-mobile in NL VLAN300).
How to change this to get an internetconnection?
My UTP cable (comes from the mediaconverter goes to WAN, then LAN cable to switch (also directly to laptop) gets no internet connection.
Is this board usable for T-Mobile in NL, with VLAN 300?
Settings for switch in C7: https://ibb.co/7WGz4xM

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdb9:3209:03e7::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.123'
	option gateway '192.168.1.1'
	option dns '192.168.1.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config interface 'wanb'
	option proto 'dhcp'
	option multipath 'on'
	option metric '20'
	option ifname 'eth0.300'

Don't know if it makes sense but in my C7 (with working internet), my network setting is:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd14:bb58:f2cb::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option proto 'dhcp'
	option ifname 'eth0.300'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname 'eth0.300'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 3 4 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '6t 1t'
	option vid '300'

This should be the same on your C7 and R2S.

You are missing the ".300" in your wan on the R2S. You've defined this under "wanb" which is fine, if you've added "wanb" to your wan firewall zone. You may want to just delete wanb and add ".300" to wan.

Also, you have a "option gateway '192.168.1.1'" under your lan, I don't think you want that. Even if you have wanb in your wan firewall, wanb has a metric of 20 so all your traffic is going to go to 192.168.1.1.

1 Like

@Tommiefr as @db215 mentioned, you've added additional sections in your /etc/config/netwok

I am using a customised build of OpenWrt and was having issues with tagged traffic on eth0 interface. I am working on it to see if it's consistent across build.

If tagged traffic on eth0 doesn't work, use eth1 (i.e. switch WAN and LAN ports)

Use this configuration (default LAN/WAN):

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb9:3209:03e7::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.1.1'
        option ifname 'eth1'

config interface 'wan'
        option ifname 'eth0.300'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0.300'
        option proto 'dhcpv6'

Note:

  • If the above configuration still doesn't work for you, swap the LAN/WAN ports. i.e. use eth0 for LAN and eth1 for WAN, in that case, eth1.300 will be your wan ifname.

  • You might have to clone your Archer C7 WAN mac address (if that's what your ISP requires).

2 Likes

@jayanta525 @db215; my internet is working!! Thnx!

Next problem is to have the filesystem write protected.... I cannot upload (OVPN files) / change settings / do updates (see attachment)
In here I am trying to update the base files but getting an eror

Try with Putty, i can login but after typing the password i get this error:

I installed the EXT4 image: ( openwrt-rockchip-armv8-friendlyarm_nanopi-r2s-ext4-sysupgrade.img.gz

Tried with this one (squashfs version): openwrt-rockchip-armv8-friendlyarm_nanopi-r2s-squashfs-sysupgrade.img.gz as well, but this one I cannot configure at all...

I installed the IMG file with Rufus tot SD card.

How to get the filesystem writeable again?

Install ext4, update with squashfs and then do factory reset

1 Like

Hello, @Tommiefr

  • The release were made to be a quick-trial image.

  • The release builds might not have all the required packages, specially the kmod-packages. Although, those can be used as daily drivers, but those are not intended to serve that purpose.

  • on boot, ext4 filesystem is mounted as read-only, this seems to be an issue with openwrt/master, and it should be fixed by now.

  • You need to compile your own build, will all the packages you require from the source. You can follow the steps on GitHub or here to get started with CI/CD.

OR, you could try with the lastest preview release from here: https://github.com/jayanta525/openwrt-nanopi-r2s/releases/tag/v2.0r1

1 Like

Thnx for the great support on this, @jayanta525 ! Really hope a 'stable' version will come out soon!
Impressive what you already achieved! I am a noob building the image but i will wait for a solution!

For me personally i do not need to install additional packages but configure them, so writable, will be very usefull

Will try @EnfermeraSexy solution tomorrow. Perhaphs this works! Simply install ext4 and in openwrt update it?

My R2S system is still running fine after a month. Now using the better black case for cooling, temps stay below 50°C always (45°C now). Built from jayanta repo with included USB wi-fi driver (wi-fi still works). I rebuilt after the v2.0 release, that image runs fine as well. I am able to edit and write files to the system.

Snapshot releases will be even better.

Thanks @jayanta525!

2 Likes

Is it possible to share the builts somewhere?
I have now installed the original friendly version but i prefer this one

Sure, but you should compile this with the packages you need. I didn't include OpenVPN, so it's probably not useful for you. If you can't compile, you may be better off using friendly until snapshot release.

Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for openvpn-mbedtls:
 *      kernel (= 5.4.50-1-bd4cc498bfaff5f8c49e51163dfb31a0)
 * opkg_install_cmd: Cannot install package openvpn.

2 Likes

I think that if you dont use openvpn-openssl you won't take advantage of crypto acceleration from the rockchip.