NanoPI R2C Plus: No find trust.img!

Hi Developers,

I bought a NanoPI R2c Plus device and I am interested in using it with standard OpenWRT.

I downloaded the current snapshot from here: https://openwrt.org/toh/hwdata/friendlyarm/friendlyarm_nanopi_r2c-plus

After that, I flashed it onto an SD card using balenaEtcher.

I Used the serial console to watch messages while booting.

Unfortunately, the boot process stops rather quickly complaining about a missing file trust.img. Complete list of messages as follows:

DDR version 1.1        8
ID:0x805 N
In
DDR4
333MHz
Bus Width=32 Col=10 Bank=4 Bank Group=2 Row=15 CS=1 Die Bus-Width=16 Size=1024MB
ddrconfig:14
OUT
Boot1 Release Time: May 13 2019 17:34:36, version: 2.50
ChipType = 0x11, 248
mmc2:cmd19,100
SdmmcInit=2 0
BootCapSize=2000
UserCapSize=7456MB
FwPartOffset=2000 , 2000
mmc0:cmd5,20
SdmmcInit=0 0
BootCapSize=0
UserCapSize=15193MB
FwPartOffset=2000 , 0
StorageInit ok = 149021
Raw SecureMode = 0
SecureInit read PBA: 0x4
SecureInit read PBA: 0x404                                                      
SecureInit read PBA: 0x804                                                      
SecureInit read PBA: 0xc04                                                      
SecureInit read PBA: 0x1004                                                     
SecureInit ret = 0, SecureMode = 0                                              
atags_set_bootdev: ret:(0)                                                      
GPT part:  0, name:            uboot, start:0x4000, size:0x2000                 
GPT part:  1, name:            trust, start:0x6000, size:0x2000                 
GPT part:  2, name:             misc, start:0x8000, size:0x2000                 
GPT part:  3, name:             dtbo, start:0xa000, size:0x2000                 
GPT part:  4, name:         resource, start:0xc000, size:0x8000                 
GPT part:  5, name:           kernel, start:0x14000, size:0x14000               
GPT part:  6, name:             boot, start:0x28000, size:0x18000               
GPT part:  7, name:           rootfs, start:0x40000, size:0x120000              
GPT part:  8, name:         userdata, start:0x160000, size:0x1c4cbdf            
find part:uboot OK. first_lba:0x4000.                                           
find part:trust OK. first_lba:0x6000.                                           
LoadTrust Addr:0x6000                                                           
LoadTrust Addr:0x6400                                                           
LoadTrust Addr:0x6800                                                           
LoadTrust Addr:0x6c00                                                           
LoadTrust Addr:0x7000                                                           
LoadTrust Addr:0x7400                                                           
LoadTrust Addr:0x7800                                                           
LoadTrust Addr:0x7c00                                                           
Addr:0x6000 No find trust.img!                                                  
LoadTrustBL error:-3                                                            
Raw SecureMode = 0                                                              
SecureInit read PBA: 0x4                                                        
SecureInit read PBA: 0x404                                                      
SecureInit read PBA: 0x804                                                      
SecureInit read PBA: 0xc04                                                      
SecureInit read PBA: 0x1004                                                     
SecureInit ret = -2, SecureMode = 0                                             
SoftReset, 183611 us

I would be happy for any ideas on how to approach this.

Thank you very much in advance.

https://forum.openwrt.org/t/nanopi-r2s-plus-out-4-year-review-of-r2s/183342/16
I am not an expert on these different hardware models but this has actually happened before.

But I am not even sure it is a working development device yet.