Nanopi r1 squashfs resize partition

I prepared an sdcard using balena etcher and a squash image for my device.

the sdcard has 3 partitions ( the 2nd one is the squash partitition and after that free space of 16GB.

How can i reclaim that free space in openwrt or do i have to resize the squash partition?

Depends on what you want it for, storage, or openwrt storage.

what would be best for installing packages and my scripts and pcaps ?

Using the ext4 image, if there's one, easier to resize :slight_smile:

But you probably want to resize the squashfs then.

Search the forum, there are several threads about it.

I prefer the squashfs as i read theres a lot less writes on the sdcard.

shouldn't be less, perhaps data/space wise, since it's a compressed FS.

I thought the squash was loaded readonly and extracted in memory where it is run , or am i wrong?

Even if it was, when you rebooted, all your changes would be gone?

Yes i was also puzzled where the changes / new packages were written

They're written in the remaining space, outside the ro part, that comes with the openwrt image, it's still squashfs:ed, but not ro.

ro = read only

The squashfs behaves more like a router fw though, the ext4 as a regular Linux fs.

Do you mean in the same partition as the squash image?

You think using ext4 wouldnt put extra strain on my sdcard?

Not sure how the squashfs is partitioned, haven't researched it, tbh.

Like I said, you do same amount of writes using both FSes, the size of the writes will however differ.

What about rebooting to factory settings using ext4 vs squashfs ?

Or upgrading to a newer version ?

That's where they differ, the squashfs kan be upgraded using a new squashfs image, the ext4 can't.

Same with resetting, can be done with the squashfs, not sure if it can, using ext4.

Thx for the info , i will try first with the squash image and see how it performs.

You probably won't notice any difference between the two.

Good luck.

1 Like

Unfortunately im not getting an ip from the Lan port.
I tried 3 different sd cards openwrt squash img and ext4 image and armbian.
Tried with balena etcher and directly with dd command.
I assume the nanopi is not working correctly.