Nanopi Neo WAN interface not working

I have a D-link 2730U modem-router which is not supported by OpenWrt so I installed it on a Nanopi Neo h3. I deleted my internet connection on D-link and created a bridge on it instead. You can see it here:
And configured Nanopi like this:


Nanopi with its only ethernet interface is connected to D-link. As you can see, the problem is, WAN always returns some errors. The first one is Unknown error (USER_REQUEST). The others are Unknown error (AUTH_TOPEER_FAILED) and Unknown error (NEGOTIATION_FAILED).
I'm new to this and I don't know what to do. Also, I'm not even sure about my configurations and I have no idea how to test it! The question is what should I do now? How can it be done?

Are you sure about this?


not really! But I also tried "eth0", and result is the same.

I am not sure you can have WAN and LAN on the same interface, or how to make it work without VLANs.

I would review the configuration on the modem/router, including how it connects with the server. On the router, I would also see a complete log on the connection attempts.


According to this, it can be. I'll check if VLAN can solve the problem.
The OpenWrt log is as below if anyone can figure it out:

Wed Apr  1 00:31:32 2020 daemon.notice netifd: Interface 'wan' is now down
Wed Apr  1 00:31:32 2020 daemon.notice netifd: Interface 'wan' is setting up now
Wed Apr  1 00:31:33 2020 daemon.err insmod: module is already loaded - slhc
Wed Apr  1 00:31:33 2020 daemon.err insmod: module is already loaded - ppp_generic
Wed Apr  1 00:31:33 2020 daemon.err insmod: module is already loaded - pppox
Wed Apr  1 00:31:33 2020 daemon.err insmod: module is already loaded - pppoe
Wed Apr  1 00:31:33 2020 pppd[21302]: Plugin loaded.
Wed Apr  1 00:31:33 2020 pppd[21302]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.7
Wed Apr  1 00:31:33 2020 daemon.notice pppd[21302]: pppd 2.4.7 started by root, uid 0
Wed Apr  1 00:31:48 2020 daemon.warn pppd[21302]: Timeout waiting for PADO packets
Wed Apr  1 00:31:48 2020 daemon.err pppd[21302]: Unable to complete PPPoE Discovery
Wed Apr  1 00:31:48 2020 pppd[21302]: Exit.

Thank you for your time.

The single port configuration described for e.g. a TL-WA703N uses the wifi interface for the lan. Your board doesn't have wifi so you would need to set up what is called a "one-armed" router. There VLANs run on the Ethernet port and an external VLAN-capable switch is used to separate them to the modem and to the LAN devices. It would be simpler to buy a device that has two ports.


Actually, I have a usb wifi adapter, but I can't find a driver for it! The board doesn't recognize it.
Thank you for your help

Those messages indicate the router is not reaching a server at the other end of the connection. Please, show us the config page for the connection on the modem.

I just reset the modem, and configured wireless, disabled its dhcp server, and created bridge in this page

Sorry, I meant that page but configured to connect from the modem. I want to see how is the connection configured on the modem, and see if there are any differences to your current configuration on the router.

sorry, here it is

I do not see anything wrong there... Only that the VCI parameter seems to change between 35 and 50, not sure if you have that covered.

I think every time I reset the modem, that VC would be created. I tried deleting it.
thank you by the way