"naming" custom DoH provider

Following the information here (https://openwrt.org/docs/guide-user/services/dns/doh_dnsmasq_https-dns-proxy), I changed my provider to my custom ControlD DoH address. But, within LUCI, it's displayed as "Unknown Provider DoH at 127.0.0.1:5053" at the top, and "Quad 101 (Taiwan)" at the bottom.

How do I change it to be "ControlD "my resolver""?

please post output this commands:

uci show dhcp; uci show https-dns-proxy

What's the version of luci-app-https-dns-proxy?

Edited to remove identifying info:

dhcp.@dnsmasq[0]=dnsmasq
dhcp.@dnsmasq[0].domainneeded='1'
dhcp.@dnsmasq[0].localise_queries='1'
dhcp.@dnsmasq[0].local='/lan/'
dhcp.@dnsmasq[0].domain='lan'
dhcp.@dnsmasq[0].expandhosts='1'
dhcp.@dnsmasq[0].authoritative='1'
dhcp.@dnsmasq[0].readethers='1'
dhcp.@dnsmasq[0].leasefile='/tmp/dhcp.leases'
dhcp.@dnsmasq[0].resolvfile='/tmp/resolv.conf.d/resolv.conf.auto'
dhcp.@dnsmasq[0].localservice='1'
dhcp.@dnsmasq[0].ednspacket_max='1232'
dhcp.@dnsmasq[0].rebind_protection='0'
dhcp.@dnsmasq[0].localuse='1'
dhcp.@dnsmasq[0].server='127.0.0.1#5053'
dhcp.@dnsmasq[0].noresolv='1'
dhcp.@dnsmasq[0].doh_backup_noresolv='-1'
dhcp.@dnsmasq[0].doh_backup_server='127.0.0.1#5053'
dhcp.lan=dhcp
dhcp.lan.interface='lan'
dhcp.lan.leasetime='12h'
dhcp.lan.dhcpv4='server'
dhcp.lan.ra_slaac='1'
dhcp.lan.force='1'
dhcp.lan.start='2'
dhcp.lan.limit='13'
dhcp.lan.ignore='0'
dhcp.lan.dns='ddb7:c8b0:1bcc:0000:0000:0000:0000:0001'
dhcp.lan.dhcpv6='disabled'
dhcp.lan.ra='disabled'
dhcp.wan=dhcp
dhcp.wan.interface='wan'
dhcp.wan.ignore='1'
dhcp.odhcpd=odhcpd
dhcp.odhcpd.maindhcp='0'
dhcp.odhcpd.leasefile='/tmp/hosts/odhcpd'
dhcp.odhcpd.leasetrigger='/usr/sbin/odhcpd-update'
dhcp.odhcpd.loglevel='4'
dhcp.guest=dhcp
dhcp.guest.interface='guest'
dhcp.guest.start='100'
dhcp.guest.limit='150'
dhcp.guest.leasetime='12h'
dhcp.guest.dns='ddb7:c8b0:1bcc:0001:0000:0000:0000:0001'
dhcp.guest.ra_flags='other-config' 'managed-config'
dhcp.guest.dhcpv6='disabled'
dhcp.guest.ra='disabled'
dhcp.@domain[0]=domain
dhcp.@domain[0].name='console.gl-inet.com'
dhcp.@domain[0].ip='10.255.254.1'
dhcp.@domain[1]=domain
dhcp.@domain[1].name='console.gl-inet.com'
dhcp.@domain[1].ip='::ffff:10.255.254.1'
https-dns-proxy.config=main
https-dns-proxy.config.update_dnsmasq_config='*'
https-dns-proxy.config.force_dns='1'
https-dns-proxy.config.force_dns_port='53' '853'
https-dns-proxy.dns=https-dns-proxy
https-dns-proxy.dns.bootstrap_dns='76.76.2.129,76.76.10.129'
https-dns-proxy.dns.resolver_url='https://dns.controld.com/MyControlD'
https-dns-proxy.dns.listen_addr='127.0.0.1'
https-dns-proxy.dns.listen_port='5053'

luci-app-https-dns-proxy 2021-07-29-1 8.7 KB Provides Web UI for DNS Over HTTPS Proxy

This is on a GL Technologies, Inc. AXT1800 with
OpenWrt 21.02-SNAPSHOT r16399+165-c67509efd7 / LuCI openwrt-22.03 branch git-21.284.67084-e4d24f0

you will need to ask for support to configure it on:

view:

or alternatively use another DoH solver:

The question and request doesn't involve ControlD, it's a LUCI question. As you can see from my provided output, https-dns-proxy.dns.resolver_url= does indeed show ControlD and I can see the requests on my dashboard.

As stated in my initial post, LUCI is displaying Unknown Provider DoH at 127.0.0.1:5053

Yes, I can choose an OpenWRT predefined ControlD provider/address, but they do not use my profiles on ControlD. I've changed the https-dns-proxy.dns.resolver_url= to point to my ControlD.

edit: I thought a screenshot would help explain what I'm looking for. I'm looking to change "1" to be "ControlD (MyControlDID)". The one that shows "Quad 101 (Taiwan)" would be nice to change, but I'm not concerned about that one.

mine seems to work correctly, try with the standard settings, if yours will work too then it's a problem with the Doh " ControlD (MyControlDID)"

or you are running a version of Openwrt that was not downloaded from the official Openwrt site (but a slightly modified version at least I assume so)

cat /etc/config/https-dns-proxy

config main 'config'
        option canary_domains_icloud '1'
        option canary_domains_mozilla '1'
        option force_dns '1'
        list force_dns_port '53'
        list force_dns_port '853'
        option procd_trigger_wan6 '0'
        list dnsmasq_config_update '0'

config https-dns-proxy
        option bootstrap_dns '1.1.1.1,1.0.0.1'
        option resolver_url 'https://cloudflare-dns.com/dns-query'
        option listen_addr '127.0.0.1'
        option listen_port '5053'
        option user 'nobody'
        option group 'nogroup'

config https-dns-proxy
        option bootstrap_dns '8.8.8.8,8.8.4.4'
        option resolver_url 'https://dns.google/dns-query'
        option listen_addr '127.0.0.1'
        option listen_port '5054'
        option user 'nobody'
        option group 'nogroup'

a test could be to add your voice to the standard settings and see if it works (add this part to /etc/config/https-dns-proxy standard)

config https-dns-proxy
        option bootstrap_dns '76.76.2.129,76.76.10.129'
        option resolver_url 'https://dns.controld.com/MyControlD'
        option listen_addr '127.0.0.1'
        option listen_port '5055'
        option user 'nobody'
        option group 'nogroup'

The luci app where you can configure customizable DoH providers is available with OpenWrt 23.05.

2 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.