N Network with Archer AX23

Hello,

I am trying to setup a 2.4GHz WiFi compatible with my existing devices (used them with an Archer C7 that died)

Tried to set one up with Radio 0 ( MediaTek MT7915E 802.11ax/b/g/n) and selected the very same settings as I did with the old Archer C7:

Mode: Master | SSID: whatevernet
BSSID: soemMacaddress
Encryption: mixed WPA2/WPA3 PSK, SAE (CCMP)
Channel: 8 (2.447 GHz)
Tx-Power: 20 dBm
Signal: -62 dBm | Noise: -92 dBm
Bitrate: 31.8 Mbit/s | Country: DE

Laptop and Phone will not connect to this...

If I set a WiFi up with radio 1 ( MediaTek MT7915E 802.11ac/ax/n) - N will not show me the expected channel selection but only the one for AX networks.

So I went for "auto" - and I can connect with laptop and phone - but all old devices will not - so I assume that "N" on radio 1 is not the classic 2.4MHz WiFi - or is this an error in the firmware? If so - can I correct this on the AX23 manually?

Thanks for any hint!

BJ

Select wpa2 (psk2) encryption. Mixed mode will create issues on some client devices.

I tried that - no change!
It appears that radio 0 is treated differently to radio 1 by default - this openWRT install is fresh out of the box and I only changed the fixed IP and netmask - everything else is default...

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@OpenWrt-SG1:~# ubus call system board
{
        "kernel": "5.15.162",
        "hostname": "OpenWrt-SG1",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "TP-Link Archer AX23 v1",
        "board_name": "tplink,archer-ax23-v1",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.4",
                "revision": "r24012-d8dd03c46f",
                "target": "ramips/mt7621",
                "description": "OpenWrt 23.05.4 r24012-d8dd03c46f"
        }
}





root@OpenWrt-SG1:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd50:9e7f:d171::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ip6assign '60'
        list ipaddr '192.168.1.249/17'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'









root@OpenWrt-SG1:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '8'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'
        option country 'DE'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
        option channel 'auto'
        option band '5g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'mySSI'
        option encryption 'sae-mixed'
        option key '****************'
        option network 'lan'





root@OpenWrt-SG1:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        option ignore '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt-SG1:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


I disabled the DHCP on purpose, since I have a PiHole running within my network.

You can't run 2.4 GHz wifi on radio1 on this device. "n" doesn't stand for that capability in this case. If you enter iw list you will see the settings/frequencies available for each radio.

1 Like

This is highly unusual for two reasons...

  1. why a /17? Do you actually need to accommodate 32K hosts?
  2. Why is your router's address in the middle of the range?

It's not that either of these things are technically wrong, but especially older embedded devices may have (badly) hard coded assumptions, such as /24 networks and/or the router being at the top of bottom of the range (.1 or .254 in a /24 network).

I recommend using channels 1, 6, or 11.

For 5g, usually 40MHz channels are used:

I still see sae-mixed.

Thanks for the time you have put in this!

I use the IPs in 192.168.yy.xx for where yy > 1 for iot devices just for easier organisation. The same settings worked well with the old device.

Channel 8 is the optimum I get in my environment (several WiFis are close by)

I switched back to mixed mode since this worked well with the old router and WEP2 only did not solve the issues.

The reason 8 is not optimal is that it sits between 6 and 11 (this part is obvious). What this means is that you'll actually get interference/noise from nearby devices (that are using channels 6 or 11) from both channels. 1, 6, 11 are considered the non-overlapping channels. The ones in between are subject to noise from the neighboring channels. Channels 2-5 and 7-10 are considered guard-bands. You can think of it like dense housing like apartments or townhomes or other close-proximity configurations. You will probably be able to hear noise from your immediate neighbors, but not (as much) from the ones 2 doors down. Same deal with the wifi channel selection for 2g.

2 Likes


While it might sound counterintuitive at first, only the third option is usable in practice ("20MHz ch. width, without ch. 12 & 13 (United States customary)"), because that's the default channel roaster used by OEM devices around the world.

1 Like