Mysterious TX/RX bandwidth discrepancy

Hello,
I am having a strange issue with the bandwidth of my wireless interface after switching from IPfire to OpenWRT on my custom built access point.
The download bw from access point to client is about 9x slower than upload, 15 vs 130 Mbit/s, see iperf runs below.

I can't for the life of me find out whats causing this...
Has anybody got a idea?

  • Wifi channel is unused appart from my ssid, but I've tried a couple other with the no change.
  • Clients have good reception with around -40dBm in the same room and are all experiencing the same bottleneck.
  • Played around with different settings, like wifi-device.distance, require_mode and disabled firewall with no improvement.
  • Attaching to the second ethernet port of my ap yields completely expected iperf numbers of ~950Mbit/s in both directions.

Specs of AP:

OpenWRT 19.07.4  - x86 build
Intel N2800, 2GB ram
Ubiquiti SR71-E mini-pcie (Atheros AR9280)

Settings:

config interface 'lan'
	option proto 'static'
	option netmask '255.255.255.0'
	list dns '1.1.1.1'
	list dns '1.0.0.1'
	option type 'bridge'
	option ifname 'eth0 eth1'
	option gateway '10.0.0.1'
	option ipaddr '10.0.0.2'

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:1c.2/0000:03:00.0'
	option hwmode '11a'
	option country 'AT'
	option htmode 'HT40'
	option txpower '20'
	option legacy_rates '0'
	option require_mode '802.11n'
	option channel '116'

config wifi-iface 'wifi0'
	option ssid 'XXX'
	option device 'radio0'
	option mode 'ap'
	option key 'XXX'
	option network 'lan'
	option ieee80211w '2'
	option encryption 'psk2+ccmp'

Client to AP:

$ iperf3 -c 10.0.0.2
Connecting to host 10.0.0.2, port 5201
[  5] local 10.0.0.220 port 38080 connected to 10.0.0.2 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-1.00   sec  13.7 MBytes   115 Mbits/sec    0    488 KBytes       
[  5]   1.00-2.00   sec  14.1 MBytes   118 Mbits/sec    0    607 KBytes       
[  5]   2.00-3.00   sec  16.1 MBytes   135 Mbits/sec    0    635 KBytes       
[  5]   3.00-4.00   sec  17.5 MBytes   147 Mbits/sec    0    673 KBytes       
[  5]   4.00-5.00   sec  17.5 MBytes   147 Mbits/sec    0    696 KBytes       
[  5]   5.00-6.00   sec  16.2 MBytes   136 Mbits/sec    0    710 KBytes       
[  5]   6.00-7.00   sec  16.2 MBytes   136 Mbits/sec    0    710 KBytes       
[  5]   7.00-8.00   sec  16.2 MBytes   136 Mbits/sec    0    710 KBytes       
[  5]   8.00-9.00   sec  17.5 MBytes   147 Mbits/sec    0    710 KBytes       
[  5]   9.00-10.00  sec  15.0 MBytes   126 Mbits/sec    0    745 KBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   160 MBytes   134 Mbits/sec    0             sender
[  5]   0.00-10.12  sec   157 MBytes   130 Mbits/sec                  receiver

AP to client:

$ iperf3 -c 10.0.0.2 -R
Connecting to host 10.0.0.2, port 5201
Reverse mode, remote host 10.0.0.2 is sending
[  5] local 10.0.0.220 port 38108 connected to 10.0.0.2 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec  1.77 MBytes  14.9 Mbits/sec                  
[  5]   1.00-2.00   sec  1.87 MBytes  15.7 Mbits/sec                  
[  5]   2.00-3.00   sec  1.73 MBytes  14.5 Mbits/sec                  
[  5]   3.00-4.00   sec  1.94 MBytes  16.2 Mbits/sec                  
[  5]   4.00-5.00   sec  1.87 MBytes  15.7 Mbits/sec                  
[  5]   5.00-6.00   sec  1.82 MBytes  15.2 Mbits/sec                  
[  5]   6.00-7.00   sec  1.89 MBytes  15.9 Mbits/sec                  
[  5]   7.00-8.00   sec  1.90 MBytes  15.9 Mbits/sec                  
[  5]   8.00-9.00   sec  1.82 MBytes  15.2 Mbits/sec                  
[  5]   9.00-10.00  sec  1.95 MBytes  16.4 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec  19.9 MBytes  16.7 Mbits/sec    0             sender
[  5]   0.00-10.00  sec  18.6 MBytes  15.6 Mbits/sec                  receiver