My TP link C60 V2 is bricked please help me

Hi friends,

Please help me to recover my router.
Im using TP link archer c60 v2 (eu)

I wanted to get back to stock firmware. And it got bricked.

I have tried tftpd method. But it doesn't work.
Im using tftpd 64 software on my windows 10.

I have tried by this way :

  1. Ip configuration :
  • ipv4 :
  • Mask :
  1. Turned off router and connect the cable to laptop's ethernet nd router's lan1

  2. Start the tftpd software

  3. Pressed the reset button and turn on the router.

  4. After 5/6 seconds released the reset button.

  5. In tftp software I'm not getting any logs. In log tab.

  6. But in the wireshark i can see the packets after release reset button.

Kindly help me

Try (instead of I had this problem with a TP-Link Archer C7 recently, and found that both IP addresses were recommended by different articles; in my case the zero didn't work but the one did. The other thing that helped was using another hub or switch in between the computer and the router, and turning off all other connectivity on the computer, so the only thing it's connecting to, through the hub, is the TP-Link device.

1 Like

Thanks for reply, i will definitely try this tonight.

Thank you so much again