My Netgear DG834Gv4 is not bricked but I am having trouble installing the original FW

Hi everyone,

I am new to OpenWrt world but I was curious and wanted to try it with an old router I had stored (a netgear DG834Gv4). I followed the tutorial on OpenWrt's website ( and I was able to install OpenWrt 15.05 on the device.

I was able to telnet to the device and set a root password. I was also able to SSH to the device and access it through the browser (LuCI was installed by default).

The problem is that the device is super slow, I know this is probably caused by the low RAM and flash but I just wanted to try OpenWrt..

Since the device is pretty much unusable as it is I wanted to revert to its original state but I am having trouble doing this.

What I have tried:
I compiled the NFTP utility, ran the file but it always got stuck in the function where it is expecting data from the router. I tried doing this with the router normally turned on and tried running NFTP and turning the router only afterwards. Both got stuck expecting data from the router.

I created a virtual machine with a 32-bit version of Windows 10 and tried to run the recovery utility supplied by Netgear, It also got stuck when trying to upload the new firmware.

I tried the TFTP client but it also got stuck, it was not able to copy the firmware to the device. (Maybe this only works when the device is bricked?)

Lastly, I tried to use mtd (as suggested on but did not even got the part where I run the mtd program :sweat_smile: .. Because the device does not have internet I could not perform the wget command to get the original firmware on the device, so I tried to copy the firmware using WinSCP (on a windows machine) but it always ended up failing to copy the firmware.

In light of this, what else can I try to get the original firmware back on the device?

Thank you in advance and sorry for the long post :innocent:

The device is very low on specs and would not be usable with an up to date OpenWrt. 15.05 is ancient, unsupported and has vulnerabilities, so it is not worth the effort.

You wouldn't be able to copy the image on the flash, so I presume you copied it on /tmp?

Thank you for response,

I was curious about OpenWrt and just wanted to give it a go, wasn't even going to use it, only for curiosity/testing purposes :slight_smile:

Yes I tried to copy the FW file to the "/" directory and to the "/tmp" directory afterwards, none of them worked. I ran the DF command to see if it had 4MB available for the FW file and I remember the available space being more than that.. I can run that command and print here the result if that helps?

The image wouldn't fit the / for sure. In /tmp it should be fine, as it is using tmpfs from the ram for /tmp. You could also try to setup an http server on your PC and try to copy the file from the router.

Sounds like a plan :slight_smile: Will try that in a bit and let you know how it goes. Thank you

1 Like

Unfortunately it did not go well, it also stopped while trying to download the FW file. I am attaching a screenshot of the terminal. I tried twice doing this twice, they both failed but interestingly enough the size of the file was different in each try.. but that probably has nothing to do with it.

There's not enough RAM to put a large file on the RAM disk.

I think these have bootloader based http CFE recovery activated by holding down the reset button while turning the power on. The LEDs should blink in a different way. Then use a web browser to and you'll see a single page to upload firmware. The PC may need to be set with a static IP.

Thank you for answering. That makes sense the lack of RAM.

I followed your instructions to keep the reset button pressed while powering the device and indeed the router is staying in a loop where it continuously cycles its power LED between red and green.

I have set my PC to have a static IP but I cannot ping the device or access it through a browser.

I tried to run again the nmrpflash tool but it stays locked here:

I think it is from a time before nrmpflash. It could be a different IP for the CFE recovery. The CFE does not answer pings. It only does one thing, the firmware upload form.

Any idea on how I can obtain the correct IP address? And can we be sure its netmask be

According to documentation the default IP is, so you can try that.

I have tried and, neither worked. The router simply does not respond to anything while in that red/green blinking state.. This is strange because the device is not bricked, I can normally access it by browser or SSH when I boot it normally but I cant get it to revert to its original firmware.. strange

Then maybe it is not entering the recovery boot successfully. Search in case you find the procedure mentioned somewhere.