My Device Won't connected on the internet on different network

My Device Won't connected on the internet on different network . i have two networks one being the Ethernet the main one the second being a wifi network on two different inface but i cant get the internet to work on wifi network being wwan1

network

config interface 'loopback'                                                                                                                                                                                              option device 'lo'                                                                                                                                                                                               option proto 'static'                                                                                                                                                                                            option ipaddr '127.0.0.1'                                                                                                                                                                                        option netmask '255.0.0.0'                                                                                                                                                                                                                                                                                                                                                                                                config globals 'globals'                                                                                                                                                                                                 option ula_prefix 'fde9:3cda:407d::/48'                                                                                                                                                                          option packet_steering '1'                                                                                                                                                                                                                                                                                                                                                                                                config device                                                                                                                                                                                                            option name 'br-lan'                                                                                                                                                                                             option type 'bridge'                                                                                                                                                                                             list ports 'eth0'                                                                                                                                                                                                                                                                                                                                                                                                         config interface 'lan'                                                                                                                                                                                                   option device 'br-lan'                                                                                                                                                                                           option proto 'static'                                                                                                                                                                                            option ipaddr '10.17.14.1'                                                                                                                                                                                       option netmask '255.255.255.0'                                                                                                                                                                                   option ip6assign '60'                                                                                                                                                                                                                                                                                                                                                                                                     config interface 'wwan'                                                                                                                                                                                                  option proto 'dhcp'                                                                                                                                                                                              option device 'phy0-sta0'                                                                                                                                                                                                                                                                                                                                                                                                 config interface 'wwan1'                                                                                                                                                                                                 option proto 'static'                                                                                                                                                                                            option device 'phy1-ap0'                                                                                                                                                                                         option ipaddr '10.17.14.2'                                                                                                                                                                                       option netmask '255.255.255.0'     

wireless

config wifi-device 'radio0'                                                                                                                                                                                              option type 'mac80211'                                                                                                                                                                                           option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'                                                                                                                                    option band '5g'                                                                                                                                                                                                 option htmode 'HT20'                                                                                                                                                                                             option cell_density '0'                                                                                                                                                                                          option channel 'auto'                                                                                                                                                                                                                                                                                                                                                                                                     config wifi-iface 'wifinet1'                                                                                                                                                                                             option device 'radio0'                                                                                                                                                                                           option mode 'sta'                                                                                                                                                                                                option network 'wwan'                                                                                                                                                                                            option ssid 'TALKTALK84F802'                                                                                                                                                                                     option encryption 'psk2'                                                                                                                                                                                         option key '4R6C8F4N'                                                                                                                                                                                                                                                                                                                                                                                                     config wifi-device 'radio1'                                                                                                                                                                                              option type 'mac80211'                                                                                                                                                                                           option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb2/2-1/2-1:1.0'                                                                                                                            option band '5g'                                                                                                                                                                                                 option channel 'auto'                                                                                                                                                                                            option htmode 'HE80'                                                                                                                                                                                             option txpower '23'                                                                                                                                                                                              option country 'GB'                                                                                                                                                                                              option cell_density '0'                                                                                                                                                                                                                                                                                                                                                                                                   config wifi-iface 'default_radio1'                                                                                                                                                                                       option device 'radio1'                                                                                                                                                                                           option network 'wwan1'                                                                                                                                                                                           option mode 'ap'                                                                                                                                                                                                 option ssid 'Hrscraft WI-FI'                                                                                                                                                                                     option encryption 'none'       

firewall

Unfortunately, you've only included a single line of each of the two text configs, and the firewall screenshot doesn't tell us anything here.

Let's see the complete config:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

you are looking the wwan1

root@OpenWrt:~# ubus call system board
{
        "kernel": "6.6.73",
        "hostname": "OpenWrt",
        "system": "ARMv8 Processor rev 3",
        "model": "Raspberry Pi 4 Model B Rev 1.5",
        "board_name": "raspberrypi,4-model-b",
        "rootfs_type": "ext4",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0-rc6",
                "revision": "r28388-58d0057481",
                "target": "bcm27xx/bcm2711",
                "description": "OpenWrt 24.10.0-rc6 r28388-58d0057481",
                "builddate": "1737575574"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde9:3cda:407d::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.17.14.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wwan'
        option proto 'dhcp'
        option device 'phy0-sta0'

config interface 'wwan1'
        option proto 'static'
        option device 'phy1-ap0'
        option ipaddr '10.17.14.2'
        option netmask '255.255.255.0'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option band '5g'
        option htmode 'HT20'
        option cell_density '0'
        option channel 'auto'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'TALKTALK84F802'
        option encryption 'psk2'
        option key '4R6C8F4N'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb2/2-1/2-1:1.0'
        option band '5g'
        option channel 'auto'
        option htmode 'HE80'
        option txpower '23'
        option country 'GB'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'wwan1'
        option mode 'ap'
        option ssid 'Hrscraft WI-FI'
        option encryption 'none'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '0'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'
        option port '53'
        list server '10.17.14.1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'
        list dhcp_option '6,10.17.14.1'
        list dhcp_option '3,10.17.14.1'
        list dns 'fde9:3cda:407d::1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wwan1'
        option interface 'wwan1'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option force '1'
        option ra 'relay'
        option dhcpv6 'relay'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include 'nodogsplash'
        option type 'script'
        option path '/usr/lib/nodogsplash/restart.sh'

config zone
        option name 'wwan1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'wwan1'
        option masq '1'

config forwarding
        option src 'wwan1'
        option dest 'lan'

There is a problem in that the lan and wwan1 interfaces have overlapping subnets.

In order for routing to work, the subnets must be different. Change the lan to something else like 10.17.15.1.

Additionally, remove the device lines from wwan and wwan1. They do not belong in this file when they are referencing wireless:

Additionally, if wwan1 is the uplink, you will need to specify the gateway and usually also the dns.

Remove the dhcp option 3 line:

wwan1 should probably not have a DHCP server running since it's likely that there's already one upstream:

ok it works now thanks for that but I have installed nodogsplash on to openwrt and set to work of wwan1 and when i connected to the work doesn't connects it straight away without bring up the splash page

If you're having trouble with nodogsplash, that would probably be best handled in a different thread (although I suspect that the answer is that this is actually mostly abandoned and there are better options to use now).

But it seems that the core issue is resolved, right?

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

ok thanks i have fix all the problems now

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.